14:00:14 <Werner> #startmeeting Jerboa release meeting
14:00:14 <ArmbianHelper> Meeting started Sat Apr  3 14:00:14 2021 UTC.  The chair is Werner. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:14 <ArmbianHelper> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:20 <Werner> #topic check-in
14:00:26 <Heisath> Hi everyone
14:00:37 <IgorPec> hej
14:00:57 <Heisath> welcome to the release planning meeting for Armbian 21.05, please just say hi to check attendance
14:01:05 <Werner> hi
14:01:10 <JMCC> Hello
14:01:14 <jock> hi
14:01:39 <Heisath> All have a coffee ready? Shall we wait a bit more, not many people here as of yet.
14:02:03 <IgorPec> 5 min can be officially late
14:02:19 * lanefu coffee equippred
14:02:34 * IgorPec will make one quick before all come together
14:02:54 <Werner> --Nur zur Erinnerung: Der Übersetzer übersetzt so ziemlich jede Ausgangssprache ins Englische wenn -- voran gestellt wird.
14:03:01 <ArmbianHelper> Just as a reminder: the translator translates pretty much any source language into English if - is put in front. [de~>eng]
14:03:28 <Heisath> interesting that it looses one minus
14:03:32 <Werner> yeah
14:03:37 <Werner> ate it
14:05:22 <Heisath> I'll just ask already if there are any late topics you want to add to agenda: https://forum.armbian.com/topic/17216-armbian-v2105-jerboa-release-thread/?tab=comments#comment-121598
14:05:37 <Werner> #topic late topics
14:07:07 <IgorPec> late topic would be to decide for a date on business oriented meeting. to keep this one strictly technical
14:07:36 <lanefu> good idea
14:07:50 <Heisath> yeah great
14:08:05 <lanefu> late topic.. this is an easy one... add virtualization support for all arm64 boards.. (just kenrel config change)
14:08:08 <IgorPec> there are things to discuss, but perhaps not putting into here. so just when and how
14:08:25 <lanefu> IgorPec: i think same model just pick another saturday
14:08:26 <Werner> #action add virtualization support for all arm64 boards
14:08:54 <lanefu> #action pick a saturday for biz meeting
14:08:57 <Heisath> okay we waited 8 mins, so lets start.
14:09:13 <Werner> Any FYI or skip to board families?
14:09:15 <Heisath> #topic FYI
14:09:20 <Werner> #topic FYI
14:09:32 <Heisath> Igor, lanefu how is the desktop coming along?
14:09:54 <Heisath> I am not up to date how far we are with including it in the build system.
14:10:04 <IgorPec> desktop is developed by Myy, so i can only pass second hand info
14:10:18 <lanefu> i havent been tracking Myy's stuff.. but it needs another deep-dive to unwind some stuff
14:10:32 <IgorPec> there is on bug that needs to be resolved, but there is some refactoring invloved ... so a bit more work
14:10:37 <lanefu> is myy keeping status in Jira or anywhere?  i saw a big dialog in irc a while back, but i lost it
14:10:51 <Heisath> Okay so desktop is open for 21.05. I'll check Jira
14:11:03 <IgorPec> in short - AR-713
14:11:03 <ArmbianHelper> 4AR-713 6[Bug] "Board specific desktop things are going into common desktop package" reported by 3Igor Pecovnik at 2021-04-03. Status: In Progress
14:11:22 <IgorPec> this is the problem and it sgould be somehow be fixed by this weekend
14:11:37 <IgorPec> so it should be done in 21.05
14:11:55 <lanefu> ahh okay.. yes i remember experiencing that early on.. I just added myself as a watcher to the ticket
14:12:05 <Heisath> great. I how does this affect other (non desktop) boards?
14:12:11 <lanefu> s/early on/earlier when working on pbp/
14:12:11 <ArmbianHelper> lanefu meant to say: ahh okay.. yes i remember experiencing that earlier when working on pbp.. I just added myself as a watcher to the ticket
14:12:39 <IgorPec> AR-596 is also related
14:12:39 <ArmbianHelper> 4AR-596 6[Task] "Moving blobs and BSP to proper location" reported by 3Richard Neese at 2020-12-27. Status: To Do
14:13:01 <IgorPec> when this bug is solved, we can do some cleanup and move blobs to designated place
14:13:20 <IgorPec> documentation or at least how-to / example is planned
14:13:42 <Heisath> okay so for 21.05 we expect to be done with desktop and packaging changes?
14:13:45 <lanefu> Heisath: it's possible that there's overlap... historically there'd been a single BSP board deb file for customizations... so if its messed up enough a server imaeg build _could_ fail
14:14:06 <IgorPec> heisath you mean with https://armbian.atlassian.net/browse/AR-671
14:14:06 <ArmbianHelper> 4AR-671 6[Story] "Changing package namings" reported by 3Igor Pecovnik at 2021-03-12. Status: In Progress
14:14:28 <IgorPec> those are not directly related, but both could be done, yeah
14:14:42 <Heisath> yeah I would count these as big changes for Armbian 21.05, something we can present.
14:15:12 <lanefu> Is this odroidC2 Ethernet issue a concern?  https://forum.armbian.com/topic/17112-odroid-c2-no-eth0-with-latest-image/?do=findComment&comment=121848
14:15:23 <IgorPec> i only hope we will have enought ime for testing, otherwise we postope
14:15:47 <lanefu> IgorPec: should a subtask be to actually define a test process?
14:16:06 <lanefu> lol liek this? https://armbian.atlassian.net/browse/AR-694
14:16:06 <ArmbianHelper> 4AR-694 6[Story] "Create Jira-based checklist for Desktop Testing" reported by 3Lane Jennison at 2021-03-18. Status: To Do
14:16:18 <IgorPec> yes we should develop what we should test
14:17:02 <IgorPec> regarding desktop i don't have any other critical issues
14:17:12 <lanefu> K I've assigned 694 to me and put on high priority... feel free to add things to test in that list
14:17:19 <lanefu> i'm gonna try to turn that into a jira template thingy
14:17:44 <Heisath> great then we can go cycle through boards / teams
14:18:01 <Werner> allwinner?
14:18:14 <IgorPec> yes, lets do that 1st
14:18:15 <lanefu> suggestion / id... for high priority tickets and above.. we should assign due-dates tot hem
14:18:17 <Werner> #topic development Allwinner
14:18:36 <IgorPec> bugs on all winner: AR-712
14:18:36 <ArmbianHelper> 4AR-712 6[Bug] "Broken framebuffer on A20" reported by 3Igor Pecovnik at 2021-04-03. Status: To Do
14:19:07 <Heisath> is this also for the normal bananapi? Or only pro?
14:19:21 <IgorPec> AR-191 is fishy too but can't really reproduce
14:19:21 <ArmbianHelper> 4AR-191 6[Bug] "SATA doesn't show up on Banana A20" reported by 3Igor Pecovnik at 2020-03-30. Status: Backlogged
14:20:04 <IgorPec> and AR-706
14:20:04 <ArmbianHelper> 4AR-706 6[Task] "Bump Allwinner u-boot to 2021.04" reported by 3Igor Pecovnik at 2021-03-28. Status: In Progress
14:20:38 <Heisath> Do we have enough Allwinner boards in testfarm to reliable test the uboot update?
14:21:09 <IgorPec> that's hard to say, but we have quite some
14:21:27 <Werner> I have 0, 1+ and PC free for testing
14:21:29 <lanefu> I have h2,h3,h5, h6 in farm
14:21:51 <Heisath> good, we can also uboot doesnt auto upgrade, so we can just tell people via Announcement to try the new images with upgraded uboot
14:22:05 <Heisath> s/we can also/also
14:22:05 <ArmbianHelper> Heisath meant to say: good, also uboot doesnt auto upgrade, so we can just tell people via Announcement to try the new images with upgraded uboot
14:22:44 <IgorPec> i have 10-15 (don't know how to extract data from Netbox yet:)
14:23:04 <Werner> #action put out some testing images with bumped u-boot for AW out
14:23:05 <IgorPec> yeah, i would certainly vote for this upgrade
14:23:41 <IgorPec> for other allwinner. dunno ... didn't do much. others?
14:24:12 <Werner> I tried some newer ATF with H616 but had no success
14:24:25 <Werner> Not supported yet anyways
14:24:37 <IgorPec> h616 is still far. any other critical things on h6, h4, a64?
14:24:44 <IgorPec> we solved pinebook display finally
14:24:53 <Werner> nice
14:25:29 <Heisath> Amlogic next?
14:25:42 <Werner> #topic development AML
14:25:49 <IgorPec> AR-711
14:25:49 <ArmbianHelper> 4AR-711 6[Bug] "Network troubles on Nanopi K2 / Odroids" reported by 3Igor Pecovnik at 2021-04-03. Status: To Do
14:26:08 <IgorPec> i think this was resolved, but its back again
14:27:00 <lanefu> yeah its anoying... who has testers for C2?
14:27:21 <IgorPec> i have one c2 and c4 in test rig
14:27:38 <JMCC> I have a C2 too
14:28:05 <JMCC> I will give it a try
14:28:37 <IgorPec> we would need expand testing on more devices. my c2 doesn't have troubles
14:28:43 <IgorPec> c4 does
14:28:56 <IgorPec> k2+ has wrong network settings
14:30:01 <Werner> #action expand network testing on AML/Odroid boards (AR-711)
14:30:01 <ArmbianHelper> 4AR-711 6[Bug] "Network troubles on Nanopi K2 / Odroids" reported by 3Igor Pecovnik at 2021-04-03. Status: To Do
14:30:37 <IgorPec> those are problems i see, desktop is unknown to me
14:30:43 <Heisath> is AML already on 2021 uboot?
14:30:44 <IgorPec> 3d and that stuff on 5.10.y
14:30:55 <IgorPec> i think we moved to some RC ...
14:31:26 <IgorPec> https://github.com/armbian/build/blob/master/config/sources/families/include/meson64_common.inc#L8
14:31:32 <IgorPec> 2021.01
14:31:40 <IgorPec> so i would say action to move this up as well
14:31:43 <IgorPec> can't be worse
14:31:51 <Heisath> yeah at least try on dev.
14:32:16 <Werner> #action bump u-boot on AML
14:32:31 <IgorPec> #action check status of 3D support on Amlogic platform
14:32:46 <Werner> #action check status of 3D support on Amlogic platform
14:33:04 <Werner> something else or move on to marvell?
14:33:10 <Heisath> should get us to marvell
14:33:14 <Werner> #topic development Marvell
14:33:27 <Heisath> Aprayoga and Gauthier seem not to be here.
14:33:51 <IgorPec> well there is little going on marvell i think
14:33:55 <lanefu> and Pali hates us, and is not interested in supporting ebin
14:34:05 <Heisath> No major issues on marvell from my side. Some Helios4 trouble with cesa popped up
14:34:06 <Heisath> https://forum.armbian.com/topic/8486-helios4-cryptographic-engines-and-security-accelerator-cesa-benchmarking/?tab=comments#comment-121856
14:34:21 <IgorPec> and i think ZFS is also broken
14:34:24 <Heisath> Maybe move this topic to the helios4 club so the kobol guys check it out.
14:34:31 <lanefu> i'm hoping [TheBug] will chime in on that one since he's got a lot of CESA wisdom
14:34:35 <IgorPec> but its due to userland librarires
14:34:35 <lanefu> good idea
14:34:56 <Werner> #action check ZFS status
14:35:05 <Heisath> Dont know what Pali's problem is, but I'd suggest leaving him alone. Ebin is EOS anyway
14:35:31 <IgorPec> true. in case someone decide to pick it up, we can support with ideas what to do
14:35:35 <lanefu> yeah I learned that lesson
14:35:46 <IgorPec> otherwise no more ebin
14:35:48 <Heisath> I will once again try to get a more up to date uboot working, dont see much hope though
14:36:07 <Heisath> atleast Pali is pushing to mainline directly, so we benefit aswell
14:36:15 <lanefu> true
14:36:42 <Heisath> @IgorPec: Why do you thing ZFS is broken on marvell?
14:36:52 <lanefu> so ebin is already CSC... we can still leave it there right?
14:36:56 <IgorPec> not just there, sorry
14:37:09 <IgorPec> unrelated
14:37:32 <IgorPec> yeas, leave ebin as is
14:37:57 <Werner> something else or move on? little behind schedule ;)
14:38:02 <IgorPec> move on
14:38:08 <Heisath> just move on, marvell is done
14:38:10 <Werner> #topic development Rockchip
14:39:00 <Heisath> AR-593
14:39:00 <ArmbianHelper> 4AR-593 6[Bug] "Rockpi S doesn't boot mainline kernel" reported by 3Igor Pecovnik at 2020-12-26. Status: To Do
14:39:18 <IgorPec> yeah, here things are not moving anywhere
14:39:48 <IgorPec> but i guess its doable since openwrt boots modern u-boot / kernel combo
14:40:13 <Heisath> helios64 does not seem to be stable but piter and kobol are working on that
14:40:49 <IgorPec> yeah, i see some troubles. what about u-boot here?
14:41:37 <lanefu> re: u-boot.. long-term seems like we need to take a huge look at it?  investigate extliux.conf style config etc.
14:41:57 <IgorPec> extlinux support, absolutely
14:42:09 <Werner> #action explore extlinux support
14:42:19 <jock> I'm trying v2021.01 and v2021.04 for rockchip 32 bit, no success yet (gcc issue above)
14:42:23 <IgorPec> its for research.
14:43:18 <IgorPec> 32bit will  be more and more problematic
14:43:23 <JMCC> For us nostalgics who still use legacy, we added support for all the display outs in NanoPC-T4: AR-651
14:43:23 <ArmbianHelper> 4AR-651 6[Task] "NanoPC-T4 legacy: enable USB-C DisplayPort & eDP outs" reported by 3Juan at 2021-02-18. Status: In Progress
14:43:56 <IgorPec> and AR-709 was resolved
14:43:56 <ArmbianHelper> 4AR-709 6[Bug] "Tinkerboard AP crash on client connect" reported by 3Igor Pecovnik at 2021-03-29. Status: Done
14:43:56 <JMCC> Some testers are welcome, specially if some of you own a eDP display (unlikely)
14:44:05 <Werner> #info display outs enabled for t4
14:44:41 <IgorPec> for pinebookpro lanefu ?
14:44:50 <IgorPec> any major "board" realted issues?
14:44:54 <lanefu> IgorPec: i've never tested it... i thikn i have an adapter now
14:45:28 <lanefu> re kernels....  are playing on sticking iwth 5.10 for current?
14:45:36 <Werner> pbp seems fine. running 5.11 and nvme installed
14:45:38 <lanefu> s/playing/we planning/
14:45:38 <ArmbianHelper> lanefu meant to say: re kernels....  are we planning on sticking iwth 5.10 for current?
14:45:38 <IgorPec> yeah, any other idea?
14:45:53 <IgorPec> edge will go with the flow ... so
14:45:53 <lanefu> nope.. happy to see us stablizing on a mainline LTS!
14:45:58 <Heisath> sure it could be worth to stick with LTS kernel for current with all boards
14:46:30 <lanefu> so to spin back a notch.. are we in a spot wher maybe allwinner-current can go straight to mainline? or do we still need all the megi patches
14:46:47 <IgorPec> too complicated question
14:46:52 <lanefu> lol okay
14:47:01 <lanefu> maybe something to explore next release
14:47:06 <IgorPec> yeah!
14:47:09 <IgorPec> #action
14:47:10 <Werner> I'd stick with it for now since it works well
14:47:31 <IgorPec> ok, lets move on
14:47:37 <Werner> #action explore option to switch from megis sources to mainline (AW)
14:47:39 <Werner> #topic development others
14:47:49 <Heisath> Any remarks on other boards?
14:47:54 <JMCC> For info, I've been testing video HW acceleration in AW mainline, and we still need several patches if we want it to work fine and
14:48:53 <IgorPec> odroid xu4 ? anyone have idea if 5.10.y could become next current (instead of 5.4.y)
14:49:16 <buZz> IgorPec: thats exynos 5xxx ?
14:49:22 <lanefu> IgorPec: not quite yet IMHO
14:49:24 <IgorPec> exynos something
14:49:27 <JMCC> Would that mean moving legacy to 5.4?
14:49:32 <IgorPec> ok, then we do nothing here
14:49:37 <buZz> i have 5.10.something (arch) on a exynos 5800 chromebook, works reaaaally well
14:49:40 <IgorPec> 5.4.y is odroid fork
14:49:43 <lanefu> i try to have 2 of htose running 1 iwth each kernel
14:49:59 <lanefu> the latest -dev kernel is finally good, but i wouldnt switch yet
14:50:02 <IgorPec> buzz: you don't hav xu4 to explore this?
14:50:07 <lanefu> s/-dev/-edge
14:50:07 <ArmbianHelper> lanefu meant to say: the latest -edge kernel is finally good, but i wouldnt switch yet
14:50:07 <buZz> no, sorry
14:50:19 <JMCC> 5.4 is still not on par wit h4.19  in some feature, in spite of HK claiming they are dropping support for 4.19
14:50:22 <buZz> IgorPec: i might get a HC1/2 soonish though
14:50:24 <lanefu> buZz: I can add more mcsolo's to a test farm if that helps you?
14:50:30 <IgorPec> well action: to test if this is possible
14:50:50 <Heisath> I'd stay with legacy 4.19 for most boards. Diff between 4.19 and 5.4 is bigger than 5.4 and 5.10
14:50:53 <buZz> afaik HC1/2/whatever the newer model is numbered at , are all XU4 hw?
14:51:02 <Werner> #action check if bumping kernel to next LTS is possible for XU4
14:51:27 <lanefu> oh FYI if you didn't catch it, we had a kernel confi gthat was breaking docker on XU4.. i fixed that last week
14:51:29 <IgorPec> and dropping support for T3/nanopi 3
14:51:55 <IgorPec> there is nothing going on
14:52:44 <IgorPec> lets move on
14:52:48 <Werner> backlog?
14:52:59 <Heisath> buildsystem first
14:53:03 <Werner> aight
14:53:08 <Werner> #topic build system
14:53:15 <Heisath> in case anything wasnt covered in FYI at the beginning.
14:53:28 <IgorPec> AR-671
14:53:28 <ArmbianHelper> 4AR-671 6[Story] "Changing package namings" reported by 3Igor Pecovnik at 2021-03-12. Status: In Progress
14:53:43 <Werner> #info dev branch renamed to edge
14:54:04 <IgorPec> the-going is working on changing package names
14:54:45 <Heisath> what is the aim of that change?
14:55:17 <IgorPec> renaming linux-image-current-meson64_21.05.0-trunk_arm64.deb to linux-image-5.10.19-meson64_21.02.0-trunk-7.0177_armhf.deb
14:55:37 <The-going> Good health.
14:55:52 <Heisath> yeah I get that. But what does it accomplish?
14:56:15 <lanefu> it helps us follow proper versioning conventiosn for deb packages
14:56:33 <IgorPec> changing from wrong to right
14:56:44 <lanefu> we do some irregular things that sometimes make it not graceful to upgrade, replace etc
14:56:56 <Heisath> ok
14:57:03 <JMCC> Just remember to add a "Provides" field to the Debian control file of the new packages
14:57:13 <lanefu> #protip
14:57:13 <JMCC> Providing the old package name
14:57:29 <Heisath> Wont contain current/edge then for boards which have the same kernel version in both right?
14:57:31 <JMCC> Just in case someone has a custom package depending on the old naming
14:57:43 <IgorPec> correct heisath
14:57:48 <The-going> The goal is to bring the package creation process as close to debian ubuntu as possible
14:58:40 <IgorPec> i hope we will be able to push this inot 20.05
14:59:09 <Heisath> will it still be possible for armbian-config to distinguish between current and edge then? (in case same kernel is used)
14:59:19 <IgorPec> 1st part already is, renaming DEV into EDGE and patches are linked now https://github.com/armbian/build/tree/master/patch/kernel/archive
14:59:50 <IgorPec> current and edge will become meta package - this is how i understand it
14:59:56 <IgorPec> and legacy
15:00:24 <Heisath> yeah doesnt really matter, dont think we often have same kernel with different config between the versions.
15:00:34 <IgorPec> exactly
15:00:55 <Heisath> it is good to keep easier track for kernels used and recreation of older version.
15:01:16 <IgorPec> for build system is what we already discussed previously and its related more toward desktop AR-596
15:01:17 <ArmbianHelper> 4AR-596 6[Task] "Moving blobs and BSP to proper location" reported by 3Richard Neese at 2020-12-27. Status: To Do
15:01:18 <Heisath> AR-175 how is that coming along?
15:01:18 <ArmbianHelper> 4AR-175 6[Story] "Improve the recreation of "released" images" reported by 3Lane Jennison at 2020-02-22. Status: To Do
15:02:25 <IgorPec> recreation of released images is not ready yet
15:02:53 <IgorPec> not sure if we can count that for 20.05
15:02:57 <Heisath> ok we should keep that in mind if we plan to support 21.05 for a longer time (because desktop). If we do.
15:03:09 <Heisath> (btw it is 2021 already, igor)
15:03:15 <IgorPec> :)
15:03:34 <IgorPec> manual maintainace can be done for a few months, but that's not the goal
15:04:11 <Heisath> ok lets go to open issues / jira backlog
15:04:29 <Werner> #topic jira backlog
15:05:26 <IgorPec> AR-572 when the-going work is merged in
15:05:26 <ArmbianHelper> 4AR-572 6[Task] "Improve kernel changing procedure" reported by 3Igor Pecovnik at 2020-12-10. Status: To Do
15:05:31 <Heisath> Anything you want to add here? I noticed there are a lot of 'need testing' PR and easy/'good first issues' issues on github. We might look into doing those ourselves if no one pops up.
15:07:26 <lanefu> call them "good 2nd issue"
15:07:55 <IgorPec> here is difficult to discuss. we do what we can, but we can't close them all . never
15:08:19 <lanefu> IgorPec: at some point maybe we should just add a github bot, that autocloses aged out issues
15:08:25 <lanefu> most mature projects do this
15:08:31 <IgorPec> or put out bounty for closing issue
15:08:36 <lanefu> yeah
15:08:55 <Heisath> Maybe add a flag for "not essential issues" that get closed automatically after some time?
15:09:03 <IgorPec> at least poping things out, make them visible
15:09:30 <IgorPec> the same goes for "(too) difficult issue"
15:09:54 <lanefu> both those ideas are good
15:10:05 <IgorPec> "extensive research neeeded"
15:10:19 <IgorPec> perhaps some more politically correct wording ... native speakers decided
15:10:27 <Heisath> And then put up bounty with auto list for both types.
15:10:39 <IgorPec> yes, make an #action for this
15:10:44 <IgorPec> it might help y bit
15:10:47 <JMCC> I see those issues dating back to 2017, with the good ol' partners that started the project, as pieces of museum
15:10:49 <lanefu> does "needs deep dive" translate, or is that too much slang
15:11:03 <JMCC> I like them there LOL
15:11:12 <Werner> #action decide marking of difficult issues
15:11:14 <Heisath> I like that. "Not essential" and "Needs deep dive"
15:11:38 <lanefu> JMCC: i'm afraid to close the old ones and getting yelled at lol
15:12:14 <Heisath> Stuff like this is just strange: https://github.com/armbian/build/issues/2646
15:12:28 <Heisath> Who'd _want_ to do that?
15:13:11 <Heisath> I think that completes jira backlog & open issues. Go to #board support
15:13:27 <Werner> #topic board support status
15:13:40 <Werner> https://www.armbian.com/download/
15:13:43 <IgorPec> board support status - removing T3 and similar
15:13:46 <Heisath> Ebin is EOS, move to CSC or keep?
15:14:12 <lanefu> I'd say keep Ebin as CSC.. since literally the community is supporting itself
15:14:21 <lanefu> and solving problems
15:14:31 <IgorPec> what about removing "EOS" label and have CSC everything that is not supported / WIP ?
15:14:37 <Heisath> #action move ebin to CSC, link to thread with Pali in description.
15:14:49 <Werner> #action move ebin to CSC, link to thread with Pali in description.
15:14:54 <Heisath> yes. CSC and EOS are the same
15:15:03 <lanefu> ebin is already set to CSC :)
15:15:08 <lanefu> well
15:15:08 <IgorPec> just adding confusion without any real value
15:15:13 <Heisath> https://www.armbian.com/download/?device_support=Support+ended+(EOS)
15:15:20 <lanefu> we build images for CSC hto, not EOS, right?
15:15:20 <Heisath> Is it though lane?
15:15:58 <lanefu> lane@billroyall:~/GIT/build/config/boards$ ls -l *e*bin*
15:16:00 <lanefu> -rw-r--r-- 1 lane megawheel 220 Mar 27 20:39 espressobin.csc
15:16:12 <Heisath> Ah so git and webpage differ
15:16:20 <IgorPec> ok, synching /download and /config/boards
15:16:23 <IgorPec> as action
15:16:41 <IgorPec> are we O.K. with merging EOS into CSC ?
15:16:41 <Werner> #action sync website download page and /config/boards
15:17:12 <Heisath> if we want to keep EOS and CSC do diff between we build images, and we dont, we should make sure it is documented.
15:17:27 <Heisath> s/CSC do/CSC to
15:17:27 <ArmbianHelper> Heisath meant to say: if we want to keep EOS and CSC to diff between we build images, and we dont, we should make sure it is documented.
15:17:59 <Werner> It may not make a difference for us but maybe for users because on CSC somebody still may work on while on EOS probably nobody does
15:18:13 <IgorPec> but we don't know for EOS
15:18:28 <Heisath> then lets keep both and move boards WIP->SUP->CSC->EOS
15:18:32 <lanefu> i thought EOS meant we just kept the config fiel in the repo, for those who want ot build on their own
15:18:45 <lanefu> yeah i think if anythig we should merge WIP and CSC
15:18:59 <IgorPec> in term of support, EOS = CSC, none we deal with
15:19:05 <IgorPec> officially
15:19:16 <JMCC> I think keeping some image for download for EOS makes sense. It can be the only way for some people to make their old board work
15:19:41 <IgorPec> providing download or build option is something else
15:19:44 <Heisath> yeah we should not delete once working images for old boards
15:20:04 <IgorPec> and we don't
15:20:12 <Heisath> *thumbs up*
15:20:15 <IgorPec> just CSC support "we don't know"
15:20:25 <IgorPec> if things works and how
15:20:42 <lanefu> CSC == ¯\_(ツ)_/¯
15:20:44 <IgorPec> EOS is the same.
15:20:49 <IgorPec> we don't know
15:20:57 <IgorPec> the diff is the we knew once ;)
15:21:09 <IgorPec> but that doesn't help much in reality
15:21:28 <lanefu> EOS == ¯\_(ツ)_/¯  ┌∩┐(◣_◢)┌∩┐
15:21:38 <IgorPec> if we are unsure, let's leave it for next
15:21:44 <IgorPec> not important issue
15:21:49 <Heisath> yeah need only to sync the state now
15:22:01 <Heisath> I think for the users it might make a difference.
15:22:10 <IgorPec> ok, sync is the action here
15:22:22 <Heisath> Also for CSC boards, dont blame them if they ask support question in forum ;)
15:22:33 <IgorPec> we can move on
15:22:40 <Werner> Nobody blames, just marked those reports as invalid :)
15:22:59 <Heisath> Igor gets a bit overboard sometimes imho
15:23:00 <lanefu> #action don't yell at CSC questions
15:23:06 <JMCC> They should ask in the peer to peer subforum, not in the supported boards froum
15:23:10 <Werner> #action don't yell at CSC questions
15:23:12 <Heisath> yeah
15:23:15 <IgorPec> OK, then lets make this a bit more gently
15:23:29 <JMCC> Just move them to peer to peer or general chit chat
15:23:29 <lanefu> :P
15:23:30 <IgorPec> not as an "invalid report" but something more plesent
15:23:52 <Heisath> Just leave CSC support request alone, move them to peer to peer. If somebody knows, he will respond. Otherwise not.
15:23:58 <lanefu> yeah... that needs to be friendlier... and our armbianmonitor -m message is still has a bit of a harsh tone
15:24:19 <lanefu> honestly. what if we have a "community support" label
15:24:25 <IgorPec> action: make forum messages friendlier
15:24:40 <Werner> Throw ideas here: https://forum.armbian.com/forum/39-armbian-project-administration/
15:24:49 <Werner> #action make forum messages friendlier
15:25:10 <IgorPec> ok, lets move on
15:25:41 <Werner> what's left?
15:25:47 <Heisath> #meeting officer
15:25:49 <Heisath> #arm64
15:25:55 <Heisath> #business meeting
15:25:55 <IgorPec> infrastructure changes
15:26:05 <Heisath> yeah and that
15:26:06 <Werner> #topic release officer
15:26:15 <JMCC> I remember when I was starting on my OPi+2e, some Spanish webpage told you to use Armbian, but stated "Be careful wehn you ask on their forum, or they will fry you with their geek arrogance" LOL
15:26:26 <Werner> LOL
15:26:53 <lanefu> Werner: new forum topic created
15:27:00 <lanefu> https://forum.armbian.com/topic/17417-make-forum-messages-friendlier-2021-edition/
15:27:09 <Werner> marked as invalid...oh wait :P
15:27:16 <lanefu> JMCC that is hillarious
15:27:46 <lanefu> yeah and native english speakers are gettting senstive adn grandstanding that we're toixic
15:28:08 <IgorPec> alright. lanefu: perhaps we can sum infrastructure changes quickly
15:28:08 <Heisath> It is things like this https://forum.armbian.com/topic/17148-random-rant/ that leads to that. Igor, no offense, but if somebody buys helios64 for lots of bucks, I understand they expect support from kobol guys.
15:28:29 <Heisath> #topic Infrastructure
15:29:04 <IgorPec> AR-675
15:29:04 <ArmbianHelper> 4AR-675 6[Story] "Armbian General Infrastructure Improvements (non-mirror)" reported by 3Lane Jennison at 2021-03-16. Status: In Progress
15:29:14 <lanefu> k FYI IMHO Mirrors are stable and working well.. still need to add health checks / validaiton
15:29:24 <Werner> #topic infrastructure
15:29:39 <lanefu> pulling up ticket stand by
15:30:38 <IgorPec> we added few new mirrors, some under our domain, some via fosshost
15:30:44 <lanefu> bwah can some one link me that ticket.. jira is being dumb
15:31:12 <IgorPec> https://armbian.atlassian.net/browse/AR-675
15:31:12 <ArmbianHelper> 4AR-675 6[Story] "Armbian General Infrastructure Improvements (non-mirror)" reported by 3Lane Jennison at 2021-03-16. Status: In Progress
15:31:26 <lanefu> THANKS! looking now
15:32:04 <lanefu> yeah i should prioritie github actions monitoring.. i feel like that's in a weird place
15:32:13 <lanefu> netbox.. Igor and I have been making good progress there
15:32:46 <IgorPec> almost all our gear and DUT+s are in the system now
15:32:48 <lanefu> http-only repo i should probably prioritize as well... seems to be sensitive issue among some users who like to cache
15:33:31 <IgorPec> devices for testing, network eq., servers, switches, power controllers, etc. and connections between them
15:33:40 <Werner> oh btw the arbeitstier runner can be removed from the repo since it will go offline in a few days
15:34:09 <lanefu> #action remove arbeitstier runner from github
15:34:16 <Werner> #action remove arbeitstier runner from github
15:34:37 <IgorPec> do we need this runner as is?
15:34:54 <lanefu> nah we have more
15:34:59 <lanefu> mine is hardly ever getting used
15:35:03 <Werner> was just a backup
15:35:07 <IgorPec> main runner builds kernels in case things are changed
15:35:26 <IgorPec> runner "build"
15:35:39 <IgorPec> but it only runs on one machine. this is not good
15:35:56 <lanefu> IgorPec: okay let swork togther so that it can run on my box if needed
15:35:59 <IgorPec> https://snipboard.io/ezJ9D5.jpg
15:36:09 <IgorPec> this way our inventory looks like
15:36:14 <Werner> add arm64 machine as 2nd native runner?
15:36:16 <IgorPec> for internal network
15:36:38 <IgorPec> it has to be x86 atm, we can only build rootfs cache with arm64
15:36:44 <IgorPec> not "everything"
15:36:54 <Werner> ok
15:37:11 <lanefu> my box has 40 threads. it can keep up as a secondary
15:37:21 <lanefu> re arm64 runners
15:37:41 <IgorPec> anyway this CI thing has to be improved
15:37:43 <IgorPec> action
15:37:46 <lanefu> i've got beta access to aarch64.com.. so I can start provisioning smaller arm64 VMS for doing moer taive buidl stuff
15:37:55 <lanefu> yeah we need a CI epic
15:37:59 <Werner> #action improve CI
15:38:22 <IgorPec> ok
15:38:23 <lanefu> s/moer taive buidl/more native build/
15:38:23 <ArmbianHelper> lanefu meant to say: i've got beta access to aarch64.com.. so I can start provisioning smaller arm64 VMS for doing more native build stuff
15:38:45 <Werner> I guess balbes would be interested in
15:38:49 <IgorPec> infrastructure wise that's it
15:38:56 <IgorPec> still lot things in motion and 2do
15:39:22 <IgorPec> in case someone wants to join those efforts, lane and i would be happy
15:39:27 <lanefu> yeah me might be, but he still uses are bigass worksonarmbinan.armbian.com box
15:39:41 <Werner> which is good
15:39:47 <Heisath> #topic misc / arm64 or was arm64 already done in infrastructure?
15:39:57 <Werner> #topic misc / arm64
15:40:11 <lanefu> yeah like I can help whoever make the jobs run... but don't have time to like design the processes occuring inside hte jobs
15:40:16 <lanefu> like i can convert test scripts to jobs
15:40:18 <Heisath> Anything else or general arm64 info noted in FYI
15:40:55 <IgorPec> officier for next?
15:41:07 <Heisath> JMCC?
15:41:27 <JMCC> Not really
15:41:29 <Heisath> Docs say: "We need someone that is not well acquiented with the process to see if our documentation is good enough."
15:41:40 <IgorPec> basically the goal is to get us here and run the meeting script
15:41:55 <Heisath> I feel pretty good up to now. Will see how the code freeze and stuff works out
15:41:58 <JMCC> Sorry, I didn't understand
15:42:17 <IgorPec> role of the meeting officier are plain
15:42:19 <JMCC> Do you mean coordinate the next meeting
15:42:23 <IgorPec> yes
15:42:40 * jock has to go, nephew called for attention (really!)
15:42:50 <lanefu> bye jock
15:42:56 <JMCC> That would be for july, correct? I will be on holiday during june
15:43:12 <lanefu> JMCC: it's easy. you just post a thread on the forum that people ignore, and then do what we just did :P
15:43:15 <Heisath> yeah july
15:43:18 <IgorPec> July 3th
15:43:44 <Heisath> its well documented here: https://docs.armbian.com/Process_Release-Model/
15:43:52 <IgorPec> also i propose to add if not there: one week before the date another reminder
15:44:16 <IgorPec> some people simply forget if not reminded two days before meeting starts
15:44:19 <Heisath> didn't help this time. Maybe also schedule around bigger holidays?
15:44:22 <Werner> #action add reminder before next meeting
15:44:27 <JMCC> Ughh, sorry but I can't. I have to speak in a conference djune 29-july 2. I would be totally disconnected from everything else these days
15:44:33 <Werner> #action add even MOAR reminders
15:44:44 <JMCC> Rain check, I get the next meeting
15:45:06 <Heisath> ok we'll just find and select someone. Maybe Pali is interested? xD
15:45:14 <IgorPec> yeah :)
15:45:26 <Werner> He wont take any role, not even the one suggested by lane :(
15:45:29 <IgorPec> jock flew. he was second candidate
15:45:31 <IgorPec> :)
15:46:12 <Heisath> I think we just postpone it a bit. Can ask in the forum. Maybe Kobol guys will do it. Would allow them to pick a timer better suited for singapor ppl.
15:46:33 <IgorPec> yes, or those who might forgot to come.
15:46:38 <IgorPec> business meeting
15:46:51 <Heisath> reason for extra meeting?
15:47:10 <IgorPec> to discusss non technical issues
15:47:13 <Heisath> #action find release officer
15:47:28 <Werner> #action find release officer
15:47:39 <IgorPec> long term plans, what to do with armbian, in which direction to go
15:47:44 <IgorPec> relationship with vendors
15:47:56 <Heisath> ok I get it. Fear not many will attend.
15:47:57 <IgorPec> where to invest milions
15:48:06 <lanefu> first get millions?
15:48:09 <Heisath> you have millions to spare?
15:48:14 <IgorPec> :)
15:48:15 <lanefu> is biz meeting now?
15:48:23 <Heisath> can do it now :D
15:48:26 <IgorPec> just doing advertisement
15:48:34 <IgorPec> so someone will show up
15:48:42 <Heisath> collect data with our boards and sell.
15:48:52 <lanefu> I'd love to partner with somoen and get an armbian branded board
15:49:11 <lanefu> and of course Igor you're aware of my other ideas about builds as a service, etc
15:49:20 <IgorPec> also i am talking with orangepi about creating new armbian wanted board
15:49:33 <IgorPec> khadas would like to cooperate
15:49:47 <IgorPec> that kind of stuff. its a lot to work on, decide and its not just my problem
15:49:49 <lanefu> yeah?  we need a board that has our name on it
15:49:52 <lanefu> for shared branding
15:50:05 <lanefu> and shared proceeds :P
15:50:14 <Heisath> Werner will you post meetbot output to the release thread?
15:50:15 <IgorPec> that is not decided yet and those are things  for the business type of meeting
15:50:19 <Werner> clusterboard with rk3588, go big or go home :D
15:50:29 <Werner> yeah will do assuming we wrap it up here?
15:50:51 <lanefu> In theory Firefly is going to send me an R1 cluster server... so maybe we'll see some RK3588 modules that way
15:50:54 <IgorPec> so, are we generally fine with time as for todays meeting?
15:51:06 <lanefu> IgorPec: yep!
15:51:15 <JMCC> *thumbs up*
15:51:16 <Heisath> We started around 16:15 here. So about 1:30
15:51:20 <Werner> then lets hope it does not crash now ^^
15:51:23 <Werner> #endmeeting