13:02:06 <IgorPec> #startmeeting
13:02:06 <ArmbianHelper> Meeting started Sat Jan 29 13:02:06 2022 UTC.  The chair is IgorPec. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:06 <ArmbianHelper> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:02:30 <Heisath> #topic Welcome and check attendance
13:03:11 <IgorPec> checked
13:03:28 <Heisath> Say hi, state which board / family you represent or/which task/role youre taking on.
13:03:41 <Heisath> Also if any new ppl are here, maybe add then you're new.
13:04:37 <lanefu> <-- infrastructure/evangelism/lifecoach
13:04:48 <adeepv> JetHome boards (JetHub D1/H1/etc) + some amlogic magic.
13:05:00 <Heisath> <-- mvebu and release planner
13:05:11 <rpardini> <-- somewhat-all meson64 and ODROID N2 / HC4 for these meeting purposes. I'm new to meetings.
13:05:38 <Zaza> rock3a  and getting into automation engineer role
13:06:08 <IgorPec> <-- no specific boards, feeling the gab, infrastructure
13:07:00 <adeepv> i'm new to meetings too)
13:07:07 <jock> hello!
13:07:44 <Werner> Hi. Semi-AFK due to family duties. doing forum/discord/irc moderation
13:07:45 <Heisath> ok for the new ppl. we basically go over the board and feature status, check which big things will be in release and choose targets for next release cycle.
13:09:03 <Heisath> Ok biggest step I think was supported/WIP/CSC changes. I think that is done?
13:09:26 <IgorPec> not completly, i would say its still wip
13:09:57 <Heisath> I saw support status between website and git is now synced?
13:10:18 <IgorPec> relations between download - build framework and new maintainers needs to be synched and doublechedk and update when changes are needed
13:10:50 <IgorPec> in the mean time some new folks showed up, so we are behind i would say
13:11:23 <rpardini> ok but download pages already show wips and generally much better. and there's new images since jan too. could you clarify?
13:11:48 <lanefu> #action WIP Changes - new maintainers needs to be synched and doublechedk and update when changes are needed; reconcile recent new maintainers
13:11:54 <IgorPec> yes, i would open a task on "systematical check on statuses"
13:12:39 <Heisath> Also we need to add maintainer name to board config. This is something maintainers should IMHO PR by themselves for their board.
13:13:01 <IgorPec> i have open a new repo https://github.com/armbian/internal
13:13:02 <Armbian-Discord> <08T​onymac32> Agreed
13:13:17 <Heisath> Also good @ igor.
13:13:18 <lanefu> yeah we've been a little soft on that, def should have that sorted before release
13:13:31 <IgorPec> which is closed, to keep some internal stuff and that would be best to be there ( to get rid of googledocs)
13:13:57 <Heisath> Then we should make a post in announcements, and call out maintainers to add themselves via PR.
13:14:00 <lanefu> #action assure maintainer is in board config prior to release.  Prefered that new maintainers perform this task themselves via PR
13:14:01 <IgorPec> so this is just some base - each new maintaner should be listed there,
13:14:29 * rpardini plug: armbian-next would massively facilitate this
13:14:32 <Heisath> I would like to have them list themselves. To test commitment. (as lanefu #actioned).
13:15:25 <IgorPec> also one meeting on the topic of board rules should be conducted. I am not sure they are clear to everyone
13:15:48 <IgorPec> also perhaps some ideas for improvements can arrise
13:16:23 <lanefu> #action coordinate maintainer meeting to discuss mainatinership and process. mandatory for new maintaienrs
13:17:25 <Heisath> Any other overall project things to discuss?
13:17:34 <TRS-80> o/
13:17:39 <Heisath> hi trash
13:17:42 <adeepv> IgorPec will the board maintainers have access to the internal repository?
13:17:50 <IgorPec> adeepv: yes
13:17:58 * TRS-80 was trying to raise his hand :)
13:18:07 <IgorPec> TRS-80 go
13:18:47 <Heisath> its an older model, but it checks out.
13:19:18 <TRS-80> I see a lot of applicants for e.g., Board Maintainer on the forums, should I approve them?  Is there some process?  Secret vote, discussion I am not aware of?
13:19:23 <TRS-80> :D
13:19:36 <IgorPec> i am slowly talking with them
13:19:52 <IgorPec> i can forward you which are yet to be contacted
13:20:30 <IgorPec> all that are not approved yet - go
13:20:32 <TRS-80> Yes, I did not know if it was just a case of you being busy or what.  I can make an effort to idle in IRC more, esp. in -onboarding channel if that helps.
13:20:35 <Heisath> We dont need a maintainer vote. If they can fulfill the requirements (board avail, etc). Then they can maintain. If they horribly break something we can still kick them
13:20:53 <TRS-80> That's sort of what I was thinking, we could use the help.
13:20:58 <TRS-80> Just wanted to check.
13:21:05 <IgorPec> yes. its just some general welcoming and helping them around
13:21:13 <TRS-80> That I can do.  :)
13:21:17 <lanefu> yes. don't need to vote.... the guidance is losing maintainership role if they donpt participate
13:21:46 <TRS-80> Yeah I figured, just wanted to make sure as I've been away a while.  Did not know if there was policy.
13:21:53 <lanefu> cool
13:22:04 <TRS-80> I'll get on it next login.
13:22:13 <lanefu> </tangent>
13:22:22 <Heisath> Ok checking Jira we look pretty good on overall release readiness https://armbian.atlassian.net/projects/AR/versions/10009/tab/release-report-all-issues
13:22:52 <Heisath> I guess AR1068 is done? https://armbian.atlassian.net/browse/AR-1068
13:22:53 <ArmbianHelper> 4AR-1068 6[Task] "Add gnome-system-monitor to Focal and Jammy" reported by 3Igor Pecovnik at 2022-01-25. Status: To Do
13:23:04 <IgorPec> yes, can move it to done
13:23:27 <IgorPec> there are few bugs that need attention
13:23:54 <Heisath> Those seem family/board related though. No overall bugs?
13:24:26 <IgorPec> overall - facebook login on forum is not working. if that counts
13:24:31 <IgorPec> i think i forget to add it
13:24:34 <Heisath> f*ck fb
13:24:37 <IgorPec> :)
13:24:50 <TRS-80> I share your esteemed viewpoint.  :)
13:25:19 <Heisath> I'd then go to topic per family and have maintainers speak up.
13:25:22 <Heisath> #topic Allwinner
13:25:56 <IgorPec> a20 sata is broken
13:26:11 <Heisath> AR191?
13:26:13 <IgorPec> yes
13:26:39 <IgorPec> and AR-1075
13:26:39 <ArmbianHelper> 4AR-1075 6[Bug] "Allwinner video driver bug" reported by 3Igor Pecovnik at 2022-01-29. Status: To Do
13:26:57 <Heisath> I don't have Allwinner HW. Who's maintaining them?
13:27:12 <IgorPec> good question. not sure who to pin this
13:27:12 <lanefu> the maintainer hopefully
13:27:23 <Heisath> bananapipro		igor xD
13:27:25 <IgorPec> its for all boards
13:27:55 <IgorPec> julia was debugging this recently, but she didn't get any further
13:28:14 <lanefu> whoever is the most active allwinner SME should own it then
13:28:18 <Heisath> Julia is new?
13:28:24 <IgorPec> yes
13:28:37 <IgorPec> juri_
13:28:54 <Heisath> @juri_ any updates on that?
13:29:19 <IgorPec> and the other bug is https://github.com/armbian/build/pull/3240
13:29:49 <IgorPec> we have a solution but its a dirty hack
13:30:32 <IgorPec> then there is AR-246 which needs to be verified, i suspect its no more
13:30:33 <ArmbianHelper> 4AR-246 6[Bug] "SPI overlay seems to be broken" reported by 3Igor Pecovnik at 2020-05-16. Status: To Do
13:30:37 <lanefu> if we have a solution... just make a tech debt jira story for future release to un-dirty it
13:30:45 <lanefu> as a contigency
13:31:28 <IgorPec> if we will wait long enough, solution will emerge upstream. this is how i understand that problem
13:31:50 <IgorPec> this is all known for allwinner
13:31:56 <IgorPec> except general
13:32:03 <IgorPec> bumping u-boot and kernel
13:32:08 <IgorPec> AR-1074
13:32:09 <ArmbianHelper> 4AR-1074 6[Story] "Switch all CURRENT to 5.15.y and EDGE to 5.16.y" reported by 3Igor Pecovnik at 2022-01-29. Status: To Do
13:32:14 <Heisath> Yeah lets to that later.
13:32:21 <Heisath> #topic Amlogic
13:32:43 <adeepv> i think we need update kernels
13:32:53 <adeepv> to 5.15 - stable, 5.16 - edge
13:33:02 <IgorPec> i'll only add AR-1071
13:33:03 <ArmbianHelper> 4AR-1071 6[Bug] "Odroid N2 upgrade path is partially broken" reported by 3Igor Pecovnik at 2022-01-29. Status: To Do
13:33:42 <Armbian-Discord> <05f​ourheads> Are we keeping 5.4 kernels?
13:34:09 <Heisath> Can we please move general kernel discussion after the board/family topics.
13:34:19 <rpardini> ok so I've a long story, bear with me?
13:34:27 <Heisath> Is it on Amlogic?
13:34:28 <IgorPec> fourheads: for amlogic or in general?
13:34:31 <rpardini> yes
13:34:33 <rpardini> In 26/September/2021, PR #3154 was merged into master. That stabilizes meson64-current 5.10.y quite a bit and somewhat makes ODROID usable. It also clears a lot of flak other meson64's were getting due to HK's patches. Also #3155 bumped meson64 to u-boot 2021.07 to match. (I guess there were JIRA about those, but can't find them. Sorry)
13:34:34 <Heisath> shoot
13:34:35 * TRS-80 sips his coffee
13:34:37 <Armbian-Discord> <05f​ourheads> In general
13:34:48 <adeepv> rpardini beer? yes)
13:35:09 <rpardini> We didn't have any release since then, I think, and until last week we had images from August/2021 on official download pages. There's now new images since last week, but I dunno which branch they were built from.
13:35:17 <IgorPec> fourheads: in general we will discuss after hw specific
13:35:23 <rpardini> Unfortunately, in that move, edge kernel (5.15.y?) was left behind, full of weird patches and very unstable atleast for ODROIDs, and very possibly also for the other meson64s due to those infamous reboot hacks and other shit from HK; the comments in those PRs show the principle behind the clean up, but gotta find time and cycle my N2+ out of prod again, so not in 22.02 timeframe.
13:35:45 <rpardini> So for 22.02 I'd really like to get that released if it wasn't yet, but keeping 5.10.y as current. Edge is useless right on those ODROIDs.
13:35:46 <IgorPec> rpardini: those images were recreated from repository
13:35:59 <rpardini> For 22.05 I promise to rework meson64 edge together with other meson64 maintainers and get it in good/better order, but for now armbian-next has priority.
13:36:10 <Armbian-Discord> <05f​ourheads> I have an N2+, maybe I can help
13:36:26 <IgorPec> fourheads: you can pick up that bug perhaps?
13:36:37 <adeepv> rpardini I saw several patches about odroid in the kernel mailing list.don't they solve these problems?
13:36:52 <Heisath> We dont need to work hard on Edge, it is not meant to be stable.
13:37:03 <rpardini> IgorPec: yes, but from which branch?
13:37:24 <Armbian-Discord> <05f​ourheads> Sure, I can pick it up
13:37:27 <rpardini> adeepv: probably. that's why theres a big rework needed.
13:37:30 <IgorPec> rpardini: packages were not built but used those from apt repo
13:37:49 <IgorPec> this way i have updated a few images last week
13:38:45 <rpardini> ok, so imgs are new but old packages, so no, those PRs still havent seen light of day
13:39:08 <rpardini> so 22.02 would be the first to include them, *if we keep current to 5.10.y*
13:39:10 <adeepv> rpardini I also have an odroid-c4 if anything
13:39:35 <rpardini> if we bump current to 5.15.y, that work will disappear unreleased
13:40:04 <IgorPec> why? we are moving 5.10.y to legacy?
13:40:26 <rpardini> no, I'm just making the point that 5.10.y should be kept as current.
13:40:28 <adeepv> rpardini In principle, I agree. the kernel can be postponed to 22.05
13:41:02 <IgorPec> aha, well. we have the flexibility to do that
13:41:21 <IgorPec> its your call. other families will have its own logic
13:41:32 <rpardini> there's a lot of meson64 boards that can run well with edge, a bit by luck
13:41:47 <rpardini> so I don't wanna impose.
13:42:18 <lanefu> IMHO legacy should always be considerd vendor/bsp kernel....  in general I hope that one day we can have stable adn old-stable LTS kernels... 5.10.y is a prime example
13:42:32 <Armbian-Discord> <08T​onymac32> Agreed
13:42:54 <IgorPec> is there any point in having amlogic legacy?
13:42:57 <rpardini> exactly. for 22.05 we could remove vendor-legacy, and move 5.10.y to legacy, after reworking edge 5.16.y
13:43:11 <Heisath> +
13:43:24 <rpardini> I'm 99% ready to remove legacy. it's there for reference only, and the UHS fiasco
13:43:38 <Armbian-Discord> <08T​onymac32> In my opinion no, I never used it for GX(L), other than the pre-existing C2 stuff when I picked it up
13:43:50 <Armbian-Discord> <08T​onymac32> So if legacy went away I don't care in the least
13:44:12 <IgorPec> yeah. i am asking speficic for amlogic. i agree that in some cases vendor kernel is needed
13:44:45 <IgorPec> so conclusing is to keep current on 5.10.y for 22.02
13:44:52 <IgorPec> ?
13:45:03 <Heisath> Aaaand he had enough :D
13:45:20 <Armbian-Discord> <r​pardini> ok. so combo proposal is for 22.02 keep current as 5.10.y, edge as whatever; for 22.05 remove vendor legacy and move 5.10.y to legacy, and promote 5.15.y/5.16.y to current after rework
13:46:03 <IgorPec> ok, nobody is agains i guess we can file it
13:46:14 <rpardini> IRC bounced me, sorry.
13:46:15 <rpardini> ok. so combo proposal is for 22.02 keep current as 5.10.y, edge as whatever; for 22.05 remove vendor legacy and move 5.10.y to legacy, and promote 5.15.y/5.16.y to current after rework.
13:46:38 <Heisath> #action Amlogic for 22.02 keep current as 5.10.y, edge as whatever; for 22.05 remove vendor legacy and move 5.10.y to legacy, and promote 5.15.y/5.16.y to current after rework.
13:46:48 <IgorPec> ar-1061 is also to check
13:46:57 <IgorPec> AR-1061
13:46:58 <ArmbianHelper> 4AR-1061 6[Bug] "udev HDMI rules are causing flickering" reported by 3Igor Pecovnik at 2022-01-23. Status: To Do
13:47:19 <IgorPec> this is some legacy hack from i don't know when
13:47:40 <Armbian-Discord> <05f​ourheads> Which Odroid Boards?
13:47:44 <Armbian-Discord> <05f​ourheads> All of them?
13:47:48 <IgorPec> yes
13:47:49 <rpardini> ok, but on 5.15.y and thus for 22.05 timeframe...?
13:47:55 <adeepv> rpaedini ok. not very good for our devices, but quite acceptable. i'll have to revisit the patches for JetHub 5.10 again
13:48:12 <adeepv> *review )
13:48:28 <IgorPec> if edge stays on 5.15.y it should be safe enough
13:48:48 <rpardini> adeepv: I agree it's inconvenient, and appreciate the teamwork
13:49:12 <juri_> hio. :)
13:50:10 <juri_> yeah, i'm taking on all allwinner boards i can find with hardware SATA support. i'll probably take on a few without sata, but for now..
13:50:13 <rpardini> finally #help if anyone would like to undertake that rework, I'd be glad to show around, since I'm mostly doing build system work.
13:50:33 <juri_> my apologies for being late to the meeting. i didn't know we had meetings. :)
13:50:49 <Heisath> Yeah sorry I don't know all the ppls names to ping them.
13:51:02 <rpardini> that said, I guess I'm done ref 22.02.
13:51:05 <Heisath> https://forum.armbian.com/topic/19188-armbian-2202-pig-release-thread/
13:51:34 <Heisath> #topic Marvell
13:51:35 <IgorPec> fyi uboot is upped for amlogic to latest ...
13:52:06 <rpardini> IgorPec: exactly and looks great and might even solve some issues to facilitate rework.
13:52:27 <IgorPec> heisath: ok, here we only have clearfogs . so you tell us ;)
13:52:28 <rpardini> _kernel_ rework mostly now, uboot is zeroed in.
13:52:35 <Heisath> Nothing big new or problematic here. No maintainer for espressobin. Helios4 and Clearfog are running good. I will test Lk5.15 and Lk5.16
13:52:37 <Armbian-Discord> <05f​ourheads> Somehow, I thought it was 8:30am (wishful thinking) - juri you are not alone.
13:53:12 <IgorPec> upgrade current to 5.15.y would be nice if not too complicated
13:53:25 <adeepv> uboot has only bug with emmc on axg/sm1 chipset - 0001-HACK-mmc-meson-gx-limit-to-24MHz.patch fixes it
13:53:27 <Heisath> If we have little participants from east (china, australia etc.) we might move the meeting time to better suit usa and europe folks
13:54:15 <juri_> BTW, i am more than half blocked, because of AR-1054. that's going to eat at least a week of hacker time for me.. which may take me a month to find.
13:54:16 <ArmbianHelper> 4AR-1054 6[Epic] "eliminate the need to have root access to build the images." reported by 3Julia Longtin at 2022-01-15. Status: To Do
13:54:33 <Armbian-Discord> <05f​ourheads> Many times I have almost bought an espressobin - if it’s important, I can buy one and help out.
13:54:41 <Armbian-Discord> <05f​ourheads> But it seems to be less popularity
13:54:52 <Heisath> It is not popular and a pain in the butt.
13:54:52 <IgorPec> juri_: we are getting to general section afterwardsd
13:55:10 <Heisath> Maybe you could get one and try it. Pali is doing lots of mainline work for it.
13:55:13 <lanefu> foruheads i have extra v5 i can send you
13:55:17 <IgorPec> espressobin is not worth the trouble i think
13:55:32 <Heisath> Pali has done a lot. I have been following the mainline mailing lists.
13:55:42 <lanefu> yeah i think it might be usable _finally_
13:55:54 <IgorPec> yeah, we could cerainly probive something better now
13:56:32 <IgorPec> i have one v4 (i think) still in the CI, but currently offline
13:56:39 <Heisath> Also he is somewhat responsive on the forum (unless Igor is involved)
13:57:26 <lanefu> yeah but he refruses to do PR's
13:57:31 <lanefu> because his hatred is that strong
13:57:42 <lanefu> historically i've ignored his stuff becuase of that
13:57:42 <Heisath> Yeah he's a mainline fellow, which is good somewhat.
13:57:46 <lanefu> fair
13:57:53 <lanefu> yeah i mean if someone wants to run with it i'm all for it
13:58:08 <Heisath> He's also trying to get lots of clearfog / helios4 patches into mvebu.
13:58:29 <Armbian-Discord> <05f​ourheads> When we say “mainline”, it seems we mean mainline kernel, right?
13:58:38 <TRS-80> @fourheads yes
13:58:48 <Heisath> 5.15 is fine for mvebu, I'll try to test 5.16 and then upgrade.
13:58:49 <rpardini> `git am` / `git format-patch` folks generally hate Github PRs, except for some very patient souls
13:59:06 <Heisath> #topic Rockchip
13:59:17 <lanefu> mainline == mainline or derived closely mainline, and not from a vendor kernel (there's some nuances that can be explained later)
13:59:32 <IgorPec> status of u-boot on rockchip?
13:59:36 <Armbian-Discord> <05f​ourheads> Sure
14:01:15 <Armbian-Discord> <05f​ourheads> My RockPro64 just departed mainland China.  Won’t have it in time to help with this release, maybe next one.
14:01:23 <TRS-80> Looking at https://docs.google.com/spreadsheets/d/17O8X5FUxo8_567Xf0_V5ZcWC1IOcg5KSryTzKACegto/edit#gid=0, I see still no maintainer for rockpro64, is that correct?  I thought I saw someone stepping up?
14:01:45 <Armbian-Discord> <05f​ourheads> I am willing to step up after I get my board. 🙂
14:01:49 <IgorPec> AR-621
14:01:50 <ArmbianHelper> 4AR-621 6[Task] "Enable SPI boot option for PineBook Pro" reported by 3Piotr Szczepanik at 2021-01-22. Status: To Do
14:02:08 <TRS-80> @fourheads Maybe add yourself on that sheet I just posted the link
14:02:48 <lanefu> TRS-80: congratulations https://armbian.lane-fu.com/linx/eauz2kh7.tsv
14:02:55 <jock> u-boot v2021.07 is fine for 32 bit (both rk322x and rockchip families), but rk3288 tinkerboard has been left behind. Would like to move to 2022.01 soon for 32 bit, but can't test because have no tinkerboard
14:03:50 <TRS-80> lanefu: lol, I was 'thinking about it' and then realized I am not sure I have time.  Maybe I can start in secondary role, I dunno.
14:03:51 <IgorPec> for tinkerboard we would like to keep usb flashing
14:03:57 <Armbian-Discord> <08T​onymac32> Jock this is because of the ums boot mode
14:04:04 <Armbian-Discord> <08T​onymac32> I am ok leaving that feature behind
14:04:08 <Armbian-Discord> <e​rcatli> Hmm, is there a maintainer for the orpi pc?
14:04:20 <Armbian-Discord> <05f​ourheads> Added myself TRS-80
14:04:21 <Armbian-Discord> <08T​onymac32> But Igor is not, which is fine 😉
14:04:24 <TRS-80> FWIW, tilim actually PM me on forums offering to send hardware.
14:04:32 <TRS-80> @fourheads thanks, cheers
14:04:41 <TRS-80> on PINE64 forums I mean
14:04:42 <lanefu> ercatli see spreadsheet
14:04:51 <Armbian-Discord> <e​rcatli> let's see
14:05:05 <lanefu> ercatli--- we're on rockchip right now.. so follow-up after meeting
14:05:30 <Armbian-Discord> <e​rcatli> hmm, I see, there is a maintainer
14:05:45 <jock> Tonymac32: no problems with that, I guess rk3288 tinkerboard may require some u-boot config rework because of its older version if you want to upgrade
14:06:04 <Armbian-Discord> <05f​ourheads> Just be aware.  I am still waiting for the Rockpro64 to arrive. 🙂
14:06:07 <IgorPec> rockchip 3399 - usb type-c ?
14:07:20 <IgorPec> for newer models - how is the status? anyone familiar
14:08:05 <Armbian-Discord> <05f​ourheads> Remind me when we get to OrangePI
14:08:11 <Armbian-Discord> <05f​ourheads> I just got a 3 LTS
14:08:24 <Armbian-Discord> <05f​ourheads> Which we don’t even have listed.
14:08:50 <jock> IgorPec: unfortunately I'm not, rockchip64/356x is out of my range
14:09:17 <lanefu> fourheads: feel free to add
14:09:47 <IgorPec> here balbes and catallini report would be needed. i also don't know much
14:10:28 <lanefu> is Zaza here?
14:10:35 <Zaza> for rock3 rk 3568 is still wip, desktop mainline kernel is not working, usb3 not working...just basic stuff.
14:11:14 <Armbian-Discord> <08T​onymac32> On the boards I've worked on the type-c has full USB and DP alt mode working
14:11:21 <Armbian-Discord> <08T​onymac32> Rk3399
14:11:23 <lanefu> #info zaza: for rock3 rk 3568 is still wip, desktop mainline kernel is not working, usb3 not working...just basic stuff.
14:11:33 <lanefu> man i've never gotten that to work
14:11:36 <IgorPec> ok. any outstanding task needed for 3399?
14:11:38 <lanefu> but i havent tried hard
14:12:04 <Zaza> using with desktop was only possible with legacy 4.19
14:12:07 <lanefu> the contencious talking about about some ethernet bugs on rock4b? cited in forum?
14:12:14 <lanefu> s/talking/talking point/
14:12:15 <ArmbianHelper> lanefu meant to say: the contencious talking point about about some ethernet bugs on rock4b? cited in forum?
14:12:29 <Armbian-Discord> <08T​onymac32> Unfamiliar
14:12:32 <lanefu> i rebubbled that to radxa, but's chinese new year
14:12:37 <Zaza> and somehow manjaro and slack did the desktop work, but was laggy a lot
14:12:47 <IgorPec> fyi olimex has some new RK3328 boards in case someone has a desire
14:13:05 * lanefu interested if they have 2 real nics
14:13:13 <Armbian-Discord> <08T​onymac32> +
14:13:26 <IgorPec> i'll add that to forum once i got info
14:14:26 <IgorPec> moving on?
14:14:40 <Heisath> #topic board other
14:14:58 <IgorPec> i asuume here is odroid xu4
14:14:58 <Zaza> resuming for rock3a : is not so good for this february release
14:15:26 <rpardini> well, all the addings of uefi-x86 and uefi-arm64 and rpi4b from my side. those are wip.
14:15:44 <IgorPec> and those as well. should we go out with those in 22.02?
14:16:11 <IgorPec> AR-1048
14:16:12 <ArmbianHelper> 4AR-1048 6[Bug] "Rpi kernel image is not updated on upgrade" reported by 3Igor Pecovnik at 2022-01-13. Status: To Do
14:16:14 * adeepv searching board with 3+ nics)
14:16:16 <lanefu> #action rock3a remains WIP for v20.02
14:16:22 <rpardini> do we have any maintainer smoke signals? I've seen you Igor touch them, but not much else. might be I'm not up-to-date
14:16:33 <Armbian-Discord> <e​rcatli> UEFI x86? Hmm, what about an MBR image?
14:16:38 <rpardini> yep, I've not tested any upgrades at all.
14:16:58 <IgorPec> rpi seems in good shape, x86 i didn't test much, arm64 don't have hw
14:17:09 <rpardini> MBR is included for uefi-x86 via legacy i386 grub. system itself is 64-bit only though
14:17:48 <rpardini> I can't speak for the upgradeability of any of them, since that's not a scenario I encounter.
14:18:00 <IgorPec> here - for arm64 - we should probably reach out for some parners
14:18:33 <rpardini> indeed. uefi-arm64 has been tested by locals here and I've reached out to SolidRun without success except for a pat in the back.
14:18:38 <IgorPec> upgrading can be tested now, since kernels are available in repository
14:18:58 <lanefu> Tony an I have Phytium D2000's coming our way
14:19:11 <lanefu> so..... will get plenty of testing then
14:19:18 <IgorPec> when is that planned?
14:19:20 <rpardini> yeah, Phytium should be the super smooth, and testing upgrades will be fun
14:19:24 <IgorPec> i assume not for this release?
14:19:24 <lanefu> check's in hte mail
14:19:28 <lanefu> not this release
14:19:49 <lanefu> devices ariving feb-march
14:19:58 <IgorPec> i would push rpi for this release, x86 is not that much relevant, arm64 we need hw
14:20:10 <rpardini> yeah. agree
14:20:15 <lanefu> i have a rpi4 now btw
14:20:23 <rpardini> rpi4b should be noted as experimental
14:20:30 <rpardini> like: might-not-upgrade
14:20:36 <IgorPec> upgrade has to be fixed
14:20:43 <Armbian-Discord> <e​rcatli> I have an RPI 4 right now, too...
14:20:54 <lanefu> "upgrades" needs to be a whole discussion for later in meeting IMHO
14:21:00 <IgorPec> its just that its not updating image on boot partition
14:21:02 <lanefu> ercaatli wanna bea mainter
14:21:04 <rpardini> yeah. I'd say if someone (not me and not Igor) steps up to fix upgrades then ok
14:21:15 <Armbian-Discord> <e​rcatli> but all of my zeros have ended up in the trash, actually, so weird...
14:21:31 <IgorPec> AR-1048 seeking for help
14:21:32 <ArmbianHelper> 4AR-1048 6[Bug] "Rpi kernel image is not updated on upgrade" reported by 3Igor Pecovnik at 2022-01-13. Status: To Do
14:22:18 <rpardini> that said I can point to a few spots I know that need addressing for upgradeability
14:22:55 <IgorPec> anyone has a desire to look into this? He will get support from me and rpardini
14:23:05 <TRS-80> Where is Cornelius, doesn't he like maintain his own RPi repo or something?
14:23:20 <IgorPec> yes, he is around from time to time
14:23:26 <lanefu> he prefers to yell from the sidelines
14:23:30 <TRS-80> Or am I thinking of someone else(?).
14:23:42 <TRS-80> lanefu: I have been working on him, long term campaign.  ;)
14:24:28 <IgorPec> ok, lets try to fill that later.
14:24:31 <joekhoobyar> yay
14:24:32 <rpardini> ahn also the sound thing, sorry
14:24:40 <rpardini> rpi4b vs userland audio
14:24:43 <TRS-80> joekhoobyar: o/
14:25:16 <joekhoobyar> wow, this IRC client makes me feel like I'm in college again.  It's 1995 all of a sudden
14:25:29 <rpardini> not a blocker for release, but again, I don't wanna get press saying "nice but no sound" as the best thing said
14:25:29 <Heisath> Any other different board things? Otherwise move to buildsystem.
14:25:51 <IgorPec> #topic buildsystem enhancements
14:25:52 <joekhoobyar> ok, I'll continue here.  Would it help if I change my name to "fourheads" ?
14:26:09 <lanefu> just be yourself whatever head that is
14:26:14 <rpardini> joekhoobyar: not but would help if you stuck to agenda I guess
14:26:15 <Heisath> Dont care. Btw. did my #topics get ignored?
14:26:24 <Heisath> I did not see a confirmation by the bot.
14:26:37 <IgorPec> for build system - rpardini
14:26:38 <lanefu> Heisath: bot caught it
14:26:46 <Heisath> ok good :D
14:26:47 <lanefu> i think it's silent if i remember
14:26:53 <rpardini> ok so build system is suffering massive refactor
14:26:54 <Heisath> Yeah for igor it was not
14:27:04 <rpardini> but it's on separate branch, and not even close to ready for 22.02
14:27:20 <lanefu> Heisath: yeah see channel topic.. it changed
14:27:33 <joekhoobyar> I wouldn't mind helping on the refactor, rpardini - but I don't know what I don't know
14:27:35 <IgorPec> smaller changes were - patching moved under series
14:27:42 <lanefu> #help
14:27:44 <joekhoobyar> and it might not be worth readiing somebody else in
14:27:57 <IgorPec> so its little bit better in sunxi, where we have a lot of them
14:27:59 <joekhoobyar> up to you
14:28:15 * TRS-80 likes to follow PRs on GitHub, some times he even learns something
14:28:34 <IgorPec> the plen for build system is that we merge rpardini changes then detach hardware layer into separate repo
14:28:46 <IgorPec> after release
14:28:48 <rpardini> ok, so armbian-next branch will be PR'ed again after 22.02 release if all goes well
14:29:12 <lanefu> #action armbian-next transition part of roadmap imemdiately after release
14:29:45 <IgorPec> also for those that might not beeing close much, there are new functionlities https://docs.armbian.com/Developer-Guide_Extensions/
14:29:50 <IgorPec> https://docs.armbian.com/Developer-Guide_Extensions-Hooks/
14:30:25 <joekhoobyar> thanks, @Igor, will read up
14:30:28 <rpardini> oh yes, _extensions_,  that's already in for 22.02
14:30:42 <joekhoobyar> Need to learn the build system.  I am a baby
14:30:57 <IgorPec> this information should be added to this release since it was never published
14:31:07 <Heisath> Yeah
14:31:11 <IgorPec> and _juri wants that we get rid of su
14:31:19 <rpardini> I will invite all of you to play on armbian-next after finishing some things and rebasing master, which is a big work
14:31:23 <IgorPec> since we are all here - do we have some sane way?
14:31:28 <Heisath> maybe add Jira with extension info, this way we get it to changelog automatically
14:31:53 <IgorPec> there was no jira on extension topi AFAIK
14:32:08 <Heisath> exactly. Thats why I meant, create one now.
14:32:08 <rpardini> uh, it was AR-1009 I think
14:32:09 <ArmbianHelper> 4AR-1009 6[Story] "Armbian Framework extensions and UEFI support" reported by 3Igor Pecovnik at 2021-11-28. Status: In Progress
14:32:38 <IgorPec> ok, moving this in, cool
14:33:21 <rpardini> promise that _after_ armbian-next I will strictly stick to 1 thing per PR/AR
14:33:28 <rpardini> :-P
14:33:33 <Heisath> This is another task for really motivated people. Check through all the jira issues and make sure they are assigend to something, so they dont get lost.
14:33:37 * TRS-80 will believe it when he sees it :p
14:33:55 <IgorPec> heisath: TRS-80 ?:)
14:34:07 <TRS-80> I was joking with rpardini
14:34:21 <TRS-80> oh you are volunteering me
14:34:25 <IgorPec> yes ;)
14:34:26 <rpardini> heheh, you're right and it's funny :-D
14:34:27 <Heisath> It is about 244 items which are Todo or Backlogged.
14:34:38 <TRS-80> yes this is suitable to my autism, perfect job for me
14:34:39 <juri_> Heisath: file a longer version of that as a ticket, and i'll try to run with it. Jira is something i do, all day, almost every day.
14:34:56 <IgorPec> this we should do together, but someone (trs) has to push on us
14:34:59 <TRS-80> however I still was never able to auth to Jira, I will give it another try later today after meeting
14:35:06 <Heisath> Just need to check they are listed under some future release so we can find them and backlog them as neccessary.
14:35:07 <Zaza47> internet bugs somehow, now I showed as zaza47
14:35:15 <juri_> (i wear product owner / tech lead / scrum manager titles at $dayjob)
14:35:20 <Heisath> #action Cycle Jira issues which are not attached to a version.
14:35:54 <TRS-80> juri_: You are welcome to it, esp as I still have yet to be able to log in to Jira.
14:36:02 <TRS-80> Bt I will still try, anyway.
14:36:05 <TRS-80> But
14:36:15 <rpardini> ok that's all from me I think. extensions in 22.02, armbian-next in 22.05 with previews before
14:36:18 <IgorPec> for build script - this is all. i guess we can movbe to CI?
14:36:59 <Heisath> yeah
14:37:04 <Heisath> #topic CI / Infrastructure
14:37:17 <lanefu> juri_ yeah flex as hard as you want
14:37:18 <Heisath> Yeah my #topic does not work :D
14:37:24 <lanefu> #cat hearding
14:37:26 <IgorPec> #topic CI
14:37:30 <rpardini> Ahn!
14:37:33 <rpardini> see, it's the slash.
14:37:34 <lanefu> Heisath: ahh yeah that but has like a whitelist... for peple
14:37:48 <lanefu> s/but/bot
14:37:48 <ArmbianHelper> lanefu meant to say: Heisath: ahh yeah that bot has like a whitelist... for peple
14:38:07 <lanefu> #action add useres to meetint bot
14:38:20 <lanefu> works case we can just grep ^# from irc logs :)
14:38:27 <Heisath> yeah np
14:38:32 <IgorPec> ok, anyway ... servers for download https://github.com/armbian/mirror
14:38:59 <IgorPec> [thebug] lanefu might tell more about
14:39:14 <IgorPec> i was mainly into CI
14:39:37 <adeepv> I still ask to rename mirror stpete to spb :)
14:39:56 <Heisath> How are we on the forum restructure?
14:40:09 <IgorPec> this is stalled :(
14:40:22 <Heisath> The new "bug reporting" categories are sleeping beauty
14:40:33 <IgorPec> we need strnghten people
14:40:50 <lanefu> #info forum restructure impeeded by childbirth and human assets
14:41:08 <IgorPec> i have asked steeman for help around strategic changes
14:41:16 <IgorPec> he hesn't decided yet
14:41:27 <lanefu> oh yeah.. on mirrors.. there's a new redirect engine i want to cutover to... it's awesome code....
14:41:37 <lanefu> #action migrate to new redirect engine
14:42:06 <IgorPec> forum needs crew boost.
14:42:08 <lanefu> adeepv: haha it's renamed in DNS.. cert was broken needed to fix for the public name
14:42:10 <rpardini> ok wait how is forum related to CI?
14:42:17 <Heisath> sorry.
14:42:28 <lanefu> #action fix stdpete rename
14:42:36 <Heisath> I was gonna do forum / infrastructure and CI in one topic
14:42:55 <rpardini> ahn ok, n/p from me, mirror is also borderline the same, "Infra and CI"
14:43:23 <lanefu> yeah.. our _other_ category isn't extremely subdivided... now that we're more mature we can start breaking htose down tho
14:43:25 <IgorPec> for CI improvements. i have divided all action scripts to a separate repository, so its just called out from /build
14:43:25 <Heisath> CI the SD card mux boards are completely stalled. It just seems to hard for the benefit.
14:43:38 <adeepv> lanefu thanks from jethome people, they all from SPB :)
14:43:42 <lanefu> yeah we can get by enough iwth power control and curl
14:43:59 <lanefu> for image testing 80% of hte tiem
14:44:08 <rpardini> IgorPec: excellent news and should help with forks too, great work on the GHA stuff btw
14:44:29 <IgorPec> github actions are now at a very high level . if you have a 4k monitor, then you can see all at once https://github.com/armbian/build/actions/runs/1766024608
14:44:36 <lanefu> ROFL
14:44:55 <lanefu> #action backlog task: better dashbaords for actions
14:45:08 <joekhoobyar> I am willing to help with any Github Actions as well
14:45:30 <IgorPec> all actions are now stored here https://github.com/armbian/scripts/tree/master/.github/workflows
14:45:45 <IgorPec> almost all. and called from other repositories
14:45:46 <lanefu> joekhoobyar: pingme offline adn i'll give you a tour of teh runner infra if you want
14:45:48 <joekhoobyar> also, anybody else here working on it - please consider local testing with https://github.com/nektos/act
14:45:53 <joekhoobyar> it will make you faster
14:46:14 <IgorPec> zaza expressed help on testing?
14:46:19 <IgorPec> https://github.com/armbian/scripts/blob/master/.github/workflows/smoke-tests.yml
14:46:26 <joekhoobyar> sure lanefu
14:46:36 <adeepv> joekhoobyar act has too many limitations
14:46:50 <IgorPec> this is smoke test which runs update + upgrade + reboot + optional power cycle on real hardwaree
14:47:02 <rpardini> joekhoobyar: we go self-hosted runner way. nektos/act is for the "opposite" (local testing)
14:47:11 <joekhoobyar> adeepv: I don't mind limitations, if it can 10x my development
14:47:22 <joekhoobyar> Oh, I know what nektos/act is for, rpardini. :)
14:48:06 <rpardini> great, now go fix that sudo needed there.
14:48:10 <IgorPec> AR-1072
14:48:11 <ArmbianHelper> 4AR-1072 6[Story] "Visualise tests support rate" reported by 3Igor Pecovnik at 2022-01-29. Status: To Do
14:48:22 <IgorPec> this is desired next step
14:48:45 <Heisath> Ok but now release needed?
14:48:49 <Heisath> *not
14:48:59 <IgorPec> no, not for release
14:49:08 <IgorPec> it would be nice to have, but
14:49:33 <Heisath> Ok any other infra tasks? Otherwise go to "#topic general" and talk kernel upgrades.
14:50:19 <Zaza47> IgorPec, yeah I can try test it. I currently using vm's to get used to ansible playbooks and control some debian mnimal img...and doing docker stuffs, lanefu is helping me with that
14:50:40 <IgorPec> Zaza47: you have jira access?
14:50:45 <Zaza47> with orointation
14:50:52 <Zaza47> *orientation
14:51:07 <Zaza47> IgorPec nop
14:51:28 <IgorPec> i have setup scheleton for this testing, so it can do bash or ansible ... yeah. i'll sent it
14:51:33 <IgorPec> i am done with infra
14:51:36 <joekhoobyar> oh, also, feel free to send me ansible related tasks as well
14:51:45 <joekhoobyar> before we switch topics, IgorPec
14:51:50 <joekhoobyar> that is all. :)
14:51:53 <IgorPec> ok
14:52:45 <Heisath> #topic general
14:53:10 <Heisath> Where possible move current to 5.15 and edge to 5.16
14:53:25 <lanefu> so i have a laundry list of points on this
14:53:45 <Heisath> 5.15 is LTS, so it would make sense to get this to work on most boards.
14:53:46 <lanefu> 1. i strongly feel we should be able to accomodate a stable and old stable LTS
14:54:12 <lanefu> 2. we still need to overall our apt repo, and package management to minimize clobbering adn uncessasry updates
14:54:20 <joekhoobyar> have to agree with lanefu's 1
14:54:33 <IgorPec> is kernel switching not good for that?
14:54:44 <IgorPec> good enough
14:54:51 <lanefu> no
14:55:06 <Heisath> to 1. :  Keep old LTS as legacy, current LTS as current, and whatever is mainline/stable as edge.
14:55:20 <lanefu> we need to have meta packages, so that we can have stable-5.10 stable-5.15
14:55:20 <Heisath> Where to old LTS exists, use vendor kernel as legacy.
14:55:27 <IgorPec> so you mean to do this on repository level?
14:55:44 <lanefu> so that frankly is done just by better package config and naming on its own
14:55:48 <lanefu> there's a seperate issue on a repository level
14:56:14 <lanefu> which is we need to really have a repo per release for distro sepcific stuff
14:56:21 <lanefu> aka stretch/bionic/etc
14:56:32 <lanefu> that _can_ be retrofitted through better pathing
14:56:52 <lanefu> that inself will stop so many upgrade breakages
14:57:02 <lanefu> elephant in room is we need a new tool for making apt repos.. or fix the one we have
14:57:08 <lanefu> still not sure what jira stories we have for that
14:57:08 <rpardini> that goes into aptly / reprepro complexities crazinesses etc
14:57:28 <lanefu> yeah, need to turn that into a real project
14:57:41 <lanefu> fortunately doesnt require armbina-specific expertise, just debian/apt expertise
14:57:45 <lanefu> should be managable to find some help for that
14:57:50 <IgorPec> #action improve repository management
14:58:11 <IgorPec> but we also have a problem here that our main tool is badly maintained
14:58:26 <IgorPec> i am affraid we will run into serious troubles once we will start using more advanced principles
14:58:49 <rpardini> I've been moving/gathering together the repo code in armbian/build for armbian-next, but haven't really touched it.
14:59:23 <lanefu> we are already running into serious troubles by not addressing it
14:59:46 <IgorPec> no, i mean repository can crash
14:59:49 <rpardini> and from non-Armbian experience, aptly has been slow-moving and erratic, while reprepro has 1-version per-arch limitation
15:00:06 <IgorPec> it has crashed a few times and i had to manually recrate it
15:00:09 <lanefu> answer sounds liek find a new tool?
15:00:45 <IgorPec> well, a research has to be done on the topic
15:00:47 <lanefu> I can co-own that issue, if someone else will participate
15:00:53 <IgorPec> i don't know cons and pros of the other one
15:01:02 <lanefu> we need someoen external i think
15:01:20 <lanefu> there's clearly not time or passion here (not critizing, just stating)
15:01:21 <IgorPec> that would certainly help. sum a story
15:01:30 <IgorPec> that's all we can do now
15:01:36 <Armbian-Discord> <e​rcatli> making apt repos? I think... hmm
15:01:46 <adeepv> lanefu y can try to research repo with you. i have some troubles :)
15:01:56 <rpardini> yeah. and be aware -- it's some of the more complex repos ever seen, Debian or Launchpad level stuff
15:02:19 <lanefu> any existing jira stories.... gonna look
15:02:24 <IgorPec> ok,
15:02:29 <rpardini> not to dissuade of course, just to mean it's super interesting challenge
15:02:39 <lanefu> :)
15:02:42 <Armbian-Discord> <e​rcatli> right, I think I used reprepro
15:02:53 <lanefu> ercatli oky work with me on this
15:03:22 <lanefu> ercatli has the bandwidht/aptitute no pun intended
15:03:36 <joekhoobyar> omfg lanefu
15:03:53 <adeepv> y = i
15:03:57 <IgorPec> here i would also like to get an attention to armbian-config refactoring. i think it suits into this section
15:04:26 <TRS-80> Did we decide we are using Ansible now?
15:04:26 <lanefu> yeah should be at least considered related.. maybe at epic level or so
15:04:26 <rpardini> sure sounds like it
15:04:28 <IgorPec> we had a few meetings on this topic and we have a new project manager that might take a lead on this
15:04:38 <TRS-80> Or not necessarily?
15:04:59 <TRS-80> Re: Ansible, for a long time, my view was against learning 'yet another Domain Specific Language' but more recently I have been spending a little time studying it and it is a very easy / straightforward syntax with really good documentation, FWIW.  So if anyone is curious about it, I encourage you to take a look, dip your toe in, come on in the water is fine.  :)
15:05:11 <juri_> so, i have a lot of experience with ansible.
15:05:20 <joekhoobyar> I also have a lot of experience with ansible
15:05:30 <lanefu> same
15:05:35 <juri_> I would hesitate to use it unless you're ready to nixify a container for it. it's not really stable.
15:05:37 <lanefu> i also have access to some additional epert resoruces
15:06:04 <Armbian-Discord> <e​rcatli> Ansible? Never touched that, bash scripting and some testing worked fine for me, erh
15:06:08 <juri_> at $DAYJOB, i ship a docker image with ansible in it, so i can make sure to get the version that works. ansible is fragile.
15:06:11 <TRS-80> I am getting ready to re-implmenting my personal dotfiles (v3) now in Ansible, FWIW.  But I have no direct experience (yet) like guys above.
15:06:12 <lanefu> juri_: bundling def required... there's ansible-execture and a few other thigns to package it tightly
15:06:28 * IgorPec must go off for a few min
15:06:32 <joekhoobyar> to be clear - let's say the *installation* of ansible can be fragile
15:06:34 <lanefu> it woudl be an indepdent install from the rest of the OS
15:06:37 <joekhoobyar> the software itself is fine
15:07:00 <rpardini> I tolerate Ansible as one of the less-worse of the participants in that space. But hey, there's enough bash there for everyone already....
15:07:05 <TRS-80> @ercatli I was exact same, until I got tired of maintaining increasingly complex and breaky scripts all by myself, too much effort when such tools already exist like Ansible.  IMO
15:07:06 <joekhoobyar> agree on the docker container - I even sometimes get issues using pyenv or similar tools
15:07:06 <lanefu> lemme know when you all wanna talk about that.. i'll grab an SME for soem extra guidance ont hose core install problems to make it easy
15:07:11 <juri_> joekhoobyar: I have many days wasted from "this ansible works, why is my ansible code broken?" to find out the installed ansible is just.. insane.
15:07:33 <joekhoobyar> juri - totally get it
15:07:47 <joekhoobyar> in fact, at my day job, I had to bite the bullet because my peers couldn't install ansible
15:07:49 <rpardini> but.... what would we use ansible for? what problems we have does it address?
15:07:51 <juri_> docker (built with nix) just makes this easy.
15:07:51 <lanefu> SME == bff is former ansible-core team member
15:07:53 <joekhoobyar> and move to scripts instead.  that made me weep
15:08:01 <TRS-80> well yeah I guess this is a common Python related symptom, unfortunately
15:08:04 <juri_> rpardini: every thing you're using shell scripts for.
15:08:09 <lanefu> rpardini: replace all teh functionality of softy... and more elaborate system configuration
15:08:17 <Armbian-Discord> <e​rcatli> juri_: oh, god no, no docker, please
15:08:19 <TRS-80> rpardini: See my points above.
15:08:27 <rpardini> juri_ yeah please take a look at such scripts before saying that hehe
15:08:40 <joekhoobyar> rpardini, look at it this way.  imagine getting idempotency for free, with less code that bash scripts
15:08:41 <juri_> rpardini: i have. i stand behind it. :)
15:08:43 <lanefu> okay... so whole sidequest ehere
15:08:45 <joekhoobyar> that's why ansible is worth it
15:08:49 <TRS-80> replace bespoke breaky scripts
15:08:52 <TRS-80> joekhoobyar: +1
15:08:53 <rpardini> you'd implement a build system in Ansible?
15:08:54 <joekhoobyar> s/that/than
15:08:54 <ArmbianHelper> joekhoobyar meant to say: than's why ansible is worth it
15:08:56 <lanefu> anything to wrap up meeting
15:09:03 <joekhoobyar> no... helper, I didn't mean that
15:09:06 <Armbian-Discord> <e​rcatli> no, don't use ansible for a BUILD system, there's makefiles for that
15:09:10 <TRS-80> rpardini: it's more for armbian-confi
15:09:12 <TRS-80> g
15:09:24 <lanefu> rpardini:: goal ansible tightly coupled with armbian-config
15:09:27 <Armbian-Discord> <e​rcatli> ansible isn't a thing for everything, you'll end up with something that reminds everyone of how JS is
15:09:34 <TRS-80> software install / config management, I am using it dotfiles for instance
15:09:35 <rpardini> ahn. ok -- sorry for confusion. armbian-config.
15:09:52 <TRS-80> rpardini had a minor freak out there, lol
15:10:01 <IgorPec> armbian-config is a project for this whole year.
15:10:07 <juri_> so, it seems like this is a topic with strong opinions. :)
15:10:08 <lanefu> #REASSURANCE:: we know when and when not to use ansible
15:10:10 <TRS-80> BUT I JUST REWORKED THE WHOLE BUILD SYSTEM, lol
15:10:25 <joekhoobyar> rpardini, I can go off topic again, so you can vent your remaining frustrations on me?
15:10:28 <Armbian-Discord> <e​rcatli> armbian-config is a project for a year? Hmm, ncurses + golang?
15:10:33 <joekhoobyar> j/k I like poking
15:10:51 <rpardini> uhh slow down I just lost track of subject for 30 secs.
15:11:01 <TRS-80> I keed, I keed
15:11:16 <lanefu> #defering armbian-config chzt for after meeting
15:11:20 <IgorPec> yes
15:11:22 <lanefu> what's left for meeting
15:11:29 <Heisath> yeah armbian-config is never ending
15:11:32 <IgorPec> armbian-config is too big subject.
15:11:43 <Heisath> #topic board support status
15:11:54 <adeepv> What about adding something to collect statistics on installations?
15:11:54 <adeepv> such as https://sentry.io/welcome/
15:11:54 <adeepv> Of course anonymous and voluntary statistics.
15:12:00 <lanefu> --#action remove app support from boards
15:12:00 <ArmbianHelper> #action remove app support from boards [en~>eng]
15:12:09 <lanefu> s/app/all
15:12:09 <ArmbianHelper> lanefu meant to say: --#action remove all support from boards
15:12:15 <Armbian-Discord> <e​rcatli> >anonymous statistics
15:12:16 <lanefu> :troll:
15:12:27 <joekhoobyar> lol lanefu
15:12:29 <Armbian-Discord> <e​rcatli> I think most users would prefer to opt-out of that...
15:12:40 <lanefu> adeepv: yeah that's a no-go politically for any distro.. has to be opt in
15:12:40 <Heisath> we have new rules for board support, so this topic is probably not needed in the future.
15:12:43 <TRS-80> If we do anything like adeepv suggest, it should be opt in only
15:12:51 <TRS-80> like Debian popcon
15:12:53 <Heisath> We have image download counters :D
15:12:57 <lanefu> adeepv: we have decent data thanks to using our direct tool for downloads
15:13:01 <lanefu> just need to parse teh data better
15:13:05 <adeepv> we can ask on first run
15:13:09 <IgorPec> heisath: yes, we will adjust that on separate meetings
15:13:10 <lanefu> s/direct/redirect
15:13:10 <ArmbianHelper> lanefu meant to say: adeepv: we have decent data thanks to using our redirect tool for downloads
15:13:33 <adeepv> download is not running :)
15:13:43 <Heisath> So overall no changes in board support, just if a maintainer leaves or shows up.
15:13:47 <lanefu> apt.armbian.com also informative
15:13:59 <lanefu> Heisath: sounds correct
15:14:12 <Heisath> ok great
15:14:26 <IgorPec> yes, just statuses has to match reality
15:14:34 <Heisath> Yeah sure.
15:14:35 <IgorPec> not all are up2date
15:14:57 <Heisath> #action Verify board status
15:15:04 <IgorPec> and here maintainers should have more active roles
15:15:50 <Heisath> Now to further dates, any objections to release on 25. of February?
15:16:06 <Heisath> Or rather 28.?
15:16:21 <IgorPec> weekend is better
15:16:43 <joekhoobyar> yes, please.  weekend
15:16:47 <Heisath> then I will release friday. Then we have saturday if something breaks hard.
15:17:01 <joekhoobyar> my job is getting crazy demanind the past month
15:17:02 <IgorPec> for the release process - do we need rc builds?
15:17:07 <joekhoobyar> s/demanind/demanding
15:17:07 <ArmbianHelper> joekhoobyar meant to say: my job is getting crazy demanding the past month
15:17:14 <Heisath> Same do we need a Code freeze?
15:17:16 <lanefu> IgorPec: always
15:17:33 <IgorPec> but there is close to no feedback on them
15:17:36 <lanefu> we need an RC branch that we work against for fixing shit and building branches from
15:17:37 <IgorPec> we have nightly builds
15:17:45 <IgorPec> which are identical to master
15:17:59 <lanefu> doesn't matter if feedback is poor.. keep trying
15:18:15 <joekhoobyar> do we have stats on how many users are willing to install nightlies vs rcs?
15:18:15 <lanefu> we have to learn to have a release tied to a branch
15:18:19 <lanefu> otherwise its silly to even have htem
15:18:22 <joekhoobyar> it may impact how much early feedback we get
15:18:30 <TRS-80> Maybe make announcement in forum to bring attention to RCs?
15:18:35 <lanefu> no stats. we need to market RC tseting better
15:18:37 <lanefu> and sooner
15:18:39 <IgorPec> fort hat we need to rework build fremework a bit
15:18:47 <TRS-80> and IRC, etc. put in MoTD
15:18:55 <IgorPec> RC we said 2 weeks before?
15:18:56 <TRS-80> maybe tweet it out as well
15:18:57 <lanefu> TRS-80: brillaint call on motd
15:19:10 <joekhoobyar> nice
15:19:10 <lanefu> we can cut RC sooner
15:19:11 <Heisath> Yeah RC in about middle of Feb.
15:19:18 <lanefu> as soon as feature freeze is in plac,e we can make RC
15:19:28 <joekhoobyar> s/nice/nice, TRS-80/
15:19:28 <ArmbianHelper> joekhoobyar meant to say: nice, TRS-80
15:19:30 <IgorPec> ok, then lets fix what is still open and RC
15:19:32 <Heisath> 11. Feb would have been my suggestion
15:19:56 <lanefu> juri_: quick say some release and project managementy things
15:20:06 <joekhoobyar> lmao, lanefu
15:20:08 <TRS-80> or not
15:20:23 <juri_> lanefu: the right things have been said. :)
15:20:34 <Heisath> Ok last topic, next release person?
15:20:43 <lanefu> remidner: IT'S OKAY TO CHERRY-PICK FIXES FROM RC TO MASTER, VICE VERSA
15:20:54 <Werner> anything important to me within the last 2h? could not pay attention
15:21:03 <Heisath> no just keep your child happy
15:21:06 <lanefu> Werner: yeah we talked about how great you are
15:21:09 <IgorPec> next release officier - werner ;)
15:21:19 <Heisath> Nah should be one of the new ppl
15:21:21 <TRS-80> yeah, surprised you even appeared, and congratz btw
15:21:22 <Werner> Why am I even asking lol
15:21:25 <lanefu> would love to see a enthustatsic new person volunteer
15:21:27 <IgorPec> juri_ ?
15:21:35 <Heisath> Its easy, and good to start.
15:21:40 <juri_> oh no. i've already got enough on my plate. :)
15:21:45 <lanefu> be sure to overcommit yourself and burnout ASAP
15:21:50 <TRS-80> :D
15:21:54 <Armbian-Discord> <e​rcatli> ^ that's what I do
15:22:06 <lanefu> TRS-80: should do it, would be eye-opening for him
15:22:06 <stipa> not me
15:22:07 <juri_> (i did two security releases at $dayjob on friday.. one near midnight!)
15:22:09 * TRS-80 volunteers for next to nothing
15:22:18 * lanefu voluntolds TRS-80
15:22:22 <Heisath> Yeah TRS-80.
15:22:29 <TRS-80> because fear of burnout
15:22:29 <Heisath> Or TheBug?
15:22:39 <TRS-80> I send Igor some beer money to assuage my guilt
15:22:52 <lanefu> Bug just started anew roll where he's learnign development.. so actually will cut him slack this round :)
15:23:07 <Heisath> oh
15:23:18 <lanefu> [TheBug]: PS proud of you!
15:23:26 <Heisath> Well think about it guys/girls.
15:23:51 <IgorPec> yes, we will
15:24:00 <lanefu> we should review our list of no-shows
15:24:08 <joekhoobyar> wait, let's talk about armbian-config for another six hours first
15:24:13 <TRS-80> When is next release?  May, right?  I go back to work in spring probably.  I don't think I could do it then, too busy.  But I can maybe do few things next month or maybe 2.
15:24:29 <lanefu> TRS-80: you're always goin back to work
15:24:30 <IgorPec> thank you Heisath for conducting the meeting!
15:24:38 <TRS-80> yeah thanks Heisath
15:24:45 <Heisath> np
15:24:48 * rpardini claps for Heisath
15:24:53 <Heisath> Today was good response actually.
15:24:58 <Werner> then do #endmeeting and hope it does not crash :P
15:24:58 <Heisath> Last meeting was a bit horrible
15:24:59 <lanefu> yeah thanks Heisath! and i thnk yhou'ev done the few most recent ones? so def worthy of a break
15:25:13 <Heisath> #endmeeting
15:25:14 <joekhoobyar> next time I will try harder to be on time
15:25:20 <TRS-80> seems to me like he is always doing it, but I come and go a lot
15:25:23 <Werner> IgorPec has to do that since he is chair
15:25:31 <IgorPec> #endmeeting