15:04:14 <Werner> #startmeeting developer meeting
15:04:14 <ArmbianHelper> Meeting started Sat Jan  7 15:04:14 2023 UTC.  The chair is Werner. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:14 <ArmbianHelper> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:05:29 <IgorPec> #topic check-in
15:05:39 <Werner> #topic check-in
15:05:49 <Heisath> Heisath, for mvebu (clearfog & helios) here.
15:06:28 <IgorPec> i'll cover some of allwinner, some build system, infra
15:08:10 <IgorPec> anybody around @jock said he will come, @brentr its 7 am (perhaps)
15:08:44 <Heisath> jock wrote hello only 14 minutes back, so he should be here
15:08:53 <jock> yes I'm here
15:09:09 <IgorPec> cool, so we have some rockchip coverage
15:09:14 <jock> yup
15:10:06 <IgorPec> while we are waiting - any late topics?
15:11:47 <jock> @igor none from my side
15:11:53 <IgorPec> k
15:13:04 <Heisath> I don't think we need to wait any longer.
15:13:17 <IgorPec> ok
15:13:29 <Heisath> Lets go on with #topic FYI. Anything from armbian management side you want to address, Igor?
15:13:37 <Werner> #topic FYI
15:14:06 <IgorPec> from management? only that we are working hard on bringing
15:14:10 <IgorPec> this partnership program up
15:14:22 <IgorPec> to stabilise funding. progressing, slowly
15:15:01 <IgorPec> don't have much prepared in this regard
15:15:18 <Heisath> k. I have question for the Armbian Private Subscriber Forum, is that the same as the "Contributors/Maintainers lounge"?
15:15:32 <IgorPec> no, that is designed for partners
15:16:03 <IgorPec> that is answered with certainty
15:16:12 <Heisath> So not even read only to the general public?
15:16:25 <Werner> hidden (for now)
15:16:26 <IgorPec> it is still under development and until we don't define our side, its limited
15:16:46 <Heisath> Ok just wondering because the post by Bug made it sound like it is done.
15:16:47 <IgorPec> its a place where a partner can post the problem
15:16:51 <[TheBug]> Heisath: the answer I think you are looking for..
15:17:07 <IgorPec> it is done, but internally we haven't define this yet
15:17:37 <IgorPec> so far there are two partners that have asked something
15:17:43 <IgorPec> and we are working on it
15:17:54 <Heisath> Ah and we is?
15:18:00 <[TheBug]> Anyone who has been a long term contributor to Armbian and wants to participate and be able to answer questions in the pay forum, if you have been here for at least a year then we will put you into a Community Supporter state so you can have access.  To post an issue you would still need to pay, but you would be able to paricipate without payment.
15:18:19 <[TheBug]> If you are in this position please contact me directly and I will work out getting the forum changes made and it documented internally
15:19:12 <Heisath> Ok then lets continue with board status, I guess.
15:19:24 <IgorPec> yes, this is more on the business side of the armbian
15:19:36 <Heisath> #topic development Allwinner
15:19:41 <Werner> #topic development Allwinner
15:20:08 <[TheBug]> Heisath: thanks for bringing that up, I will add this note soon to the forum post on it to make it more clean for Contributor / Maintainers that give their time to Armbian -- that is still a donation
15:20:10 <IgorPec> recent troubles with allwinner
15:20:24 <[TheBug]> s/clean/clear
15:20:24 <ArmbianHelper> [TheBug] meant to say: Heisath: thanks for bringing that up, I will add this note soon to the forum post on it to make it more clear for Contributor / Maintainers that give their time to Armbian -- that is still a donation
15:20:25 <IgorPec> are related to boot loader
15:20:40 <IgorPec> some boards got troubles with 2022.07
15:20:45 <IgorPec> the same as rockchip
15:20:57 <IgorPec> then we have H616 mainline in rough state
15:21:14 <IgorPec> wireless support on Oranges is broken in 6.x
15:21:22 <IgorPec> with this new chip
15:21:59 <IgorPec> the rest is outside of my knowing. we should start cleaning patches
15:22:08 <IgorPec> Allwinner is the dirtiees
15:22:42 <Heisath> #info Allwinner has boot loader troubles
15:22:47 <IgorPec> and i did u-boot cleaning few months back. at least that part is good. for upcoming release i don't think we will bump allwinner to 6.1 with CURRENT
15:22:52 <IgorPec> that's it
15:22:52 <Heisath> #action clean Allwinner patches
15:23:27 <Heisath> #topic development Amlogic
15:23:33 <Werner> #topic development Amlogic
15:23:38 <Heisath> Anyone here for amlogic?
15:24:04 <IgorPec> i know there are troubles with eMMC driver, some timings or ... boot loader
15:24:47 <IgorPec> otherwise is in pretty decent state AFAIK
15:24:56 <IgorPec> not many patches on top of mainline
15:25:26 <Heisath> great.
15:25:32 <Heisath> #topic development Marvell
15:25:36 <Werner> #topic development Marvell
15:26:26 <Heisath> nothing new here. mvebu edge is on 6.1 now, I guess we will test that and then go to 6.1 current with the 23.05. release. Maybe retire then. Not much happening on mvebu. All the same patches not a lot but constantly breaking.
15:27:18 <IgorPec> i would propose to widen question of device retirement at the end
15:27:28 <IgorPec> its not just this device
15:27:30 <Heisath> It might make sense to attach mvebu edge to Russel Kings Clearfog Kernel tree, which gets updates often and he adjust patches. Maybe just have it auto build then via the new community release thing.
15:27:58 <IgorPec> i mean mvebu gets very low interest on forums
15:28:13 <Heisath> mvebu64 (so Ebin) is clean mainline right now, so that can stay for long probably.
15:28:16 <IgorPec> its now an old device, perhaps moving whole section down
15:28:17 <Heisath> Or it runs great :D
15:28:35 <IgorPec> i understand it works well, but if there is no support needs
15:28:41 <Heisath> Maybe not many noobs try it and get lots of small problems with irrelevant stuff like graphics and desktop.
15:28:47 <IgorPec> dedicated forum existance is not needed
15:28:52 <Heisath> true.
15:28:59 <Heisath> Also only 32bit
15:29:14 <IgorPec> and if we retire device, it has to be different at saying "its not supported"
15:29:23 <Heisath> anyway. If @manofthesea has no ebin points we can continue.
15:29:30 <IgorPec> ok
15:29:41 <Heisath> #topic development Rockchip
15:29:48 <Werner> #topic development Rockchip
15:30:09 <IgorPec> here we have a patch mess (rockchip64)đ
15:30:22 <IgorPec> @jock can tell more
15:30:42 <jock> yes, first of all rk322x and rockchip 32 bit are quite ok with kernel 6.1
15:31:09 <jock> I tested them a bit and IMHO current can go 6.1
15:31:10 <lpirl> I recently had a rk3399 (NanoPi M4v2) that got stuck in uboot, but I'll test again soon with a freshly built image.
15:31:33 <IgorPec> rockchip boards also broke with uboot 2022.07
15:31:36 <IgorPec> some of them
15:31:54 <Heisath> Remind me, why do we keep updating uboot?
15:32:09 <jock> about rockchip64, the tests I did with a 3318/3328 device, it seems to work well enough. There were some issues with broadcom bluetooth that have been fixed removing a Pinebook patch
15:32:10 <Heisath> Is there ever new features?
15:32:18 <rpardini> -- damn -- so sorry -- had bike trouble and was stranded nowhere in the rain.
15:32:23 <IgorPec> EFI support is something that might be interesting
15:32:57 <IgorPec> rpardini np. i covered you on amlogic "there are no troubles" :)
15:33:21 <jock> u-boot v2022.07 has been a wreck with 32bit rockchips
15:33:26 <IgorPec> jock: are those BC issues fixed by now?
15:33:41 <IgorPec> and what we can do to go down with patch entrophy
15:33:52 <IgorPec> u-boot / rockchip64 / media
15:34:19 <jock> yes about the patch mayhem of rockchip64, there was no consesus about converting the patches into series
15:34:31 <lpirl> I unfortunately haven't understood the implications of the uboot 2022.07 breakage yet. Are the causes known? How can board maintainers help with that?
15:35:09 <IgorPec> board maintainer can help by reporting it. I can only see it on test devices.
15:35:30 <IgorPec> https://snipboard.io/bgtBzy.jpg
15:35:38 <jock> @igor, IMHO the armbian patches could at least move to series, so they at least apply over kernel sources and don't substitute them like now
15:36:26 <lpirl> Thanks Igor, I'll have a go with fresh images soon.
15:36:36 <IgorPec> lpirl:
15:36:37 <[TheBug]> https://www.armbian.com/rc-testing/ can be used anytime for reporting issues by a maintainer. We have to reset the ticket for this cycle, but that should be done here later today.
15:36:38 <jock> @lpirl I spent quite some time months ago for u-boot v2022.07 on 32 bit rockchips, but could get it sorted out; on 64 bit rockchips it seems to work decently although
15:36:57 <IgorPec> i have move some of one boot loader back
15:37:04 <jock> *could NOT
15:38:12 <IgorPec> lpirl: open a Jira ticket in case image from download does not work / is killed by upgrade
15:38:53 <IgorPec> when we will produce RC images for next re-build, that rc-testing link applies
15:40:20 <Heisath> ok #topic development Others
15:40:27 <Werner> #topic development Others
15:40:37 <Heisath> Any other boards, Jetson?
15:40:45 <IgorPec> that is covered by media kernel AFAIK
15:41:01 <IgorPec> so more like Oleg theritory, i have open one bug lately
15:41:21 <IgorPec> switchjing kernel from current to next killed the board
15:41:32 <IgorPec> otherwise its fine
15:42:24 <Heisath> Alright then lets go to #topic buildsystem
15:42:31 <Heisath> I think here is most of the new stuff
15:42:31 <Werner> #topic build framework
15:42:59 <IgorPec> @rpardinig
15:43:16 <IgorPec> this is now covered in weekly meetings
15:43:33 <peterm6881> whats the lowest cost platform currently supported by Armbian
15:43:36 <IgorPec> as Richardo has time until end of February to finally merge NEXT in
15:44:10 <jock> @peterm6881 not the right moment to ask about
15:44:12 <Heisath> Ok so if anyone is interested in that he needs to watch the video from wednesday.
15:44:18 <IgorPec> i would encorage people to join weekly developers meetings. they are mainly focused into build framework
15:44:22 <IgorPec> yes
15:44:29 <IgorPec> there are 3 videos now
15:44:56 <jock> is the link available on the forum?
15:45:15 <IgorPec> https://forum.armbian.com/forum/39-armbian-project-administration/
15:45:20 <IgorPec> last three topics
15:45:57 <jock> tnx
15:46:05 <rpardini> yes, watch the videos, there's also the slides; try out the armbian-next branch and report the problems, either in forum or directly to me, I'm happy to happy
15:46:24 <rpardini> do expect failures -- the whole point of next is to stop-on-errors instead of fail-silently
15:46:40 <rpardini> we've addressed already 2 dozens of bugs in the last week
15:46:53 <rpardini> but everyone has different host setup, etc, so testing is the most valuable for now
15:47:52 <rpardini> (and I mean testing the build system, although testing the produced images is also ok)
15:48:28 <Heisath> Move on?
15:48:35 <Heisath> #topic infrastructure
15:48:39 <Werner> #topic infrastructure
15:48:40 <Heisath> any news here?
15:48:52 <IgorPec> yes
15:49:03 <IgorPec> we are seeking for aarch64 iron
15:49:15 <rpardini> we had a few apt mirrors trouble the last few days
15:49:20 <IgorPec> i am talking to fallen fosshost, but nothing new
15:49:36 <rpardini> might impact testing armbian-next. if that is the case: add `SKIP_ARMBIAN_REPO=yes` to command line, and it will do work without using mirrors
15:49:38 <IgorPec> i have option b and c to precoeed
15:49:53 <IgorPec> we really need to improve arm buil infrastructure
15:50:06 <[TheBug]> https://status.armbian.com/ - Has been updated, now tracks all Armbian maintained infrastructure (including internal Mirrors) and reports uptime
15:50:07 <IgorPec> for mirrors
15:50:14 <lanefu> FYI if fosshost has spare iron in the USA I can colo a box or 2 in my lanecloud Texas for you
15:50:27 <rpardini> yes. native / high-core-count arm64 iron is needed -- but also smaller builders, 4-core, 8-gig, for image building would be useful
15:50:31 <IgorPec> yeah, we have full blown uptime monitor now
15:50:46 <IgorPec> regarding redirector @cats might tell us more
15:50:48 <IgorPec> if he is around
15:50:49 <Werner> That would be really nice to have. But expensive :( https://www.hetzner.com/dedicated-rootserver/matrix-rx
15:51:21 <IgorPec> lanefu: tnx. so far i haven't got any reply from them
15:51:43 <IgorPec> only that some positive note that we are qualified
15:51:49 <Armbian-Discord> <c​ats> So the redirector is a bit stagnant currently, the code to check versions/control files is done but I believe there were some regressions with tests that caused it to not pass... I was fixing a few, but between work and other side projects it somewhat fell off.
15:52:04 <Armbian-Discord> <c​ats> I pushed everything I had up to Github so it's there for the world to see/tinker, it should be very close
15:52:05 <rpardini> yep, I've also applied for the Ampere Developer program, but so far no result from them
15:52:09 <Armbian-Discord> <c​ats> (I hope these messages get through)
15:52:51 <IgorPec> so the idea around redirector is to automatically add / remove broken mirrors
15:53:03 <IgorPec> so we won't be seeing errors anymore in case that happens
15:53:27 <Armbian-Discord> <c​ats> Yep. My ideal state of the redirector is to have multiple active nodes, backed by failover, and the ability for it to automatically say "This is outdated" - the status checks do well and monitor http/https and TLS certificates, but that version information would be icing on the cake
15:53:40 <rpardini> yes -- also redirector is "sticky" -- eg in -next, I retry 5 times every update/download... but every of the 5 times it gives out the same, possibly broken, mirror
15:54:03 <Armbian-Discord> <c​ats> It isn't actually sticky, by design it's meant to take 3 of the top mirrors available and cycle through them
15:54:25 <IgorPec> ok
15:54:39 <IgorPec> also there is some interest to develop "Wireless devices testing action script"
15:54:45 <IgorPec> which goes into this topic
15:55:19 <IgorPec> i have around 25 wifi devices that can be xporteed via tcpip to test devices, so wifi can be tested on each kernel upgrade ... automatically
15:55:34 <rpardini> that could be interesting, for the usb wireless you mean? and do usbip?
15:55:36 <IgorPec> "just" scripting has to be done ;)
15:55:41 <IgorPec> yes
15:55:46 <Armbian-Discord> <c​ats> But if there's an error or it's sticking unintentionally, the code is all on github and you could run it yourself to verify if you'd like - I'd also like to add specific location test cases so you could say force it to test and see which mirrors return from "this or this" :)
15:56:16 <rpardini> @cats nice can you post the link to the repo, I've seen it before but lost track
15:56:24 <rpardini> golang right?
15:56:54 <IgorPec> i can only add that a dedicated #infra project has been opened in Jira
15:57:00 <IgorPec> to cover those topics
15:57:13 <IgorPec> i think its for logged users only
15:58:15 <Heisath> k. Next topic would be #topic Jira backlog / open issues in github.
15:58:34 <IgorPec> armbian-config :)
15:58:48 <Werner> Either or. Not both :P
15:59:04 <Heisath> Pff ok then armbian config first maybe?
15:59:21 <Werner> #topic armbian-config
15:59:27 <Werner> As ordered :)
15:59:30 <IgorPec> ok
15:59:41 <IgorPec> after months of going wrong way
15:59:50 <IgorPec> we went right way
15:59:57 <Heisath> You learned how to use GPS?
16:00:05 <IgorPec> sgjava made base structure for configurator
16:00:24 <IgorPec> but his main goal is to intrduce IO handling libraries
16:00:41 <IgorPec> we had one person, then another tring to help
16:00:47 <IgorPec> but we can't move anywhere
16:01:42 <IgorPec> if someone has spare time, armbian-config also have meetings, fridays
16:02:07 <rpardini> it's highly intricate: armbian-config and armbian-build share stuff like /etc/armbian-release, uboot_platform.sh; also highly dependent on the overlay structure for the kernel, if bootscript / extlinux / grub, etc.
16:02:08 <IgorPec> this tool is  / will also be essential for testing features
16:02:54 <IgorPec> exactly. its important that the base structure is rock solid and that its implemented into CI at all stages
16:02:58 <Armbian-Discord> <c​ats> rpardini: https://github.com/armbian/armbian-router
16:03:09 <IgorPec> but currently we only have a prototype
16:03:11 <IgorPec> more or less
16:03:16 <rpardini> (meanwhile I can report I've heard armbian-install [nee nand-sata-install] is working good / great)
16:03:30 <IgorPec> yes, this tool got attention and love
16:03:41 <IgorPec> it was improved, bugs fixed, works well
16:04:07 <IgorPec> still we would need to extend it
16:05:21 <IgorPec> i have little to add to armbian-config - if everyone adds a small segment, we can move it
16:05:50 <Heisath> Ok now onwards to #topic jira backlog
16:05:57 <Werner> #topic jira backlog
16:06:08 <Heisath> https://armbian.atlassian.net/jira/software/c/projects/AR/boards/1/backlog?issueLimit=100
16:06:27 <Heisath> Check here and move any you are still working on for 23.03 to the release so it gets included in there.
16:06:37 <Heisath> I am not going to go through all of them.
16:06:49 <Heisath> https://armbian.atlassian.net/projects/AR/versions/10013/tab/release-report-all-issues
16:07:02 <Heisath> From the assigned issues there is only about 4 left "Todo"
16:07:10 <IgorPec> some could be closed. yes. Release log will be done from things in Jira
16:07:27 <IgorPec> so please add at least a tittle and close it, if its not there yet
16:07:39 <IgorPec> for things you want to see in the release log
16:08:20 <IgorPec> many those things in backlog can also be just closed. i am closing them now
16:08:24 <IgorPec> which i know
16:10:31 <Heisath> #topic open issues
16:10:37 <Werner> #topic open issues
16:10:59 <Heisath> Same thing here there is too many to actually cycle them - but please check if there are matching issues for PRs which have been completed.
16:11:23 <Heisath> #action adjust the release documentation. There is 10 min for cycling these issues planned :D
16:11:43 <Heisath> #topic Board Support Status updates
16:11:57 <Werner> #topic Board Support Status Updates
16:12:20 <Heisath> I think we should introduce a new category for EOL boards.
16:12:25 <IgorPec> yes
16:12:30 <IgorPec> or retired
16:12:47 <Heisath> Not recommended for new projects/design
16:12:54 <IgorPec> what sounds better. i don't want that people dump armbian and go to somewhere else
16:13:08 <IgorPec> as somewhere else they never even try to fix anything
16:13:35 <Heisath> So the path is WIP -> Supported -> Retired. Parallel to that there is CSC
16:13:39 <IgorPec> that's why this is a bit problematic. if we say "not supported", people take this very serious
16:13:54 <jock> shouldn't retired/EOL boards become community supported and be left there for community only support for the time being?
16:13:55 <IgorPec> or "Matured" ?
16:14:13 <IgorPec> since last release, images are now frozen by default
16:14:29 <IgorPec> this means - if they boot well now, they will bot well in years from now
16:14:41 <lpirl> +1 for CSC
16:14:45 <IgorPec> "Matured / no active development"
16:14:58 <IgorPec> i am seeking for word of assurance, something possitive
16:15:34 <Heisath> Careful with that, I would not want people to then choose old "matured" devices expecting greatness and fully working stuff to then have really old HW.
16:15:35 <lpirl> "done" :)
16:16:03 <rpardini> Matured to me means, fully mainlined, zero-patches, working well
16:16:07 <IgorPec> look again - images will reamain in frozen state
16:16:20 <IgorPec> yes, but mainline often breaks
16:16:39 <IgorPec> and we will not know
16:17:15 <rpardini> true.
16:17:22 <IgorPec> so the question is more like - if we say retiring boards a,b,c, ... where to put them? https://github.com/armbian/community
16:17:30 <IgorPec> and forget about
16:17:39 <IgorPec> or something in between
16:17:56 <Heisath> Maybe make a poll in forum?
16:17:58 <IgorPec> becasue /community has everything
16:18:21 <IgorPec> why not
16:18:25 <lpirl> "archive" but that again also might not motivate people to stay
16:18:45 <IgorPec> yes, i don't want that people not use those
16:19:01 <IgorPec> as they are still very much better then lets say Debian or some other build
16:19:10 <IgorPec> which all claim "supported"
16:19:12 <lpirl> "library" (heavily overloaded term)
16:19:34 <Heisath> Ok maybe make a poll in the forum for naming. Just add the options named now.
16:19:47 <Heisath> As for where to put them, community is fine I guess.
16:19:47 <IgorPec> ok, lets give Werner some work ;)
16:20:18 <IgorPec> and now which boards to retire?
16:20:45 <IgorPec> bananapi pro, m1, cledarfor, devtem
16:21:10 <[TheBug]> BTW - Random for anyone who didn't know and is interested -- the w LONG TERM archives for armbian are https://armbian.tnahosting.net/archive and https://xogium.performanceservers.nl/archive all others are eventually cleaned as space is constrained
16:21:13 <IgorPec> orange H3
16:21:37 <IgorPec> yes, but we need to put some very old stuff from https://www.armbian.com/download/
16:21:38 <Heisath> Whole mvebu(64) I would retire after 23.05. when we have stable 6.1 kernel
16:22:04 <Heisath> @Bug those links are horrible we need to put them somewhere ppl can find them.
16:22:09 <IgorPec> we need to keep providing images, that'ts the point
16:22:24 <IgorPec> and we should not tag those images as some low quality materiral
16:22:47 <IgorPec> which happens if we say "not supported". that's what i want to emphasise
16:23:02 <Heisath> Could call it not maintained anymore
16:23:06 <IgorPec> please come out with concrete ideas which to remove
16:23:50 <IgorPec> also one idea is to have a section on the download pages, below
16:24:01 <Heisath> +1 for that.
16:24:48 <IgorPec> hot stuff, maturer+stable, community (link to that page)
16:25:12 <Heisath> Now it could also be some nsfw stuff
16:25:41 <IgorPec> ok
16:26:13 <Heisath> #topic release officer then?
16:26:20 <IgorPec> yes
16:26:24 <Heisath> <-
16:26:27 <IgorPec> ok
16:26:29 <Werner> #topic release officer
16:26:46 <Heisath> this one right here sheriff.
16:26:57 <IgorPec> Heisath, if you can, it would help a lot
16:27:20 <IgorPec> if someone steps out even better
16:27:25 <Heisath> I will be unavailable from next weekend until 11. of feb.
16:27:41 <Heisath> so can only really do something after that for codefreeze etc.
16:27:48 <IgorPec> this we are talking about April [1st]
16:28:01 <Armbian-Discord> <c​ats> TheBug: I also have the full archive on my LV mirror
16:28:10 <[TheBug]> Nice!
16:28:15 <[TheBug]> :)
16:28:18 <IgorPec> dates for code freeze and release are setpo
16:28:46 <IgorPec> we will take care of call for testers when far enough
16:29:03 <Heisath> good.
16:29:05 <IgorPec> but 1st of april will be around in no time ;)
16:29:11 <Heisath> then #topic misc
16:29:15 <Werner> #topic misc
16:29:38 <Heisath> Anything anyone wants to say about anywhat?
16:30:06 <[TheBug]> Werner thanks for running meeting :D
16:30:09 <Heisath> Okay then lets close the meeting.
16:30:16 <jock> I have a question about the committees...
16:30:23 <Heisath> Oh yeah right thoooose
16:30:31 <jock> :9
16:30:32 <jock> :)
16:31:12 <[TheBug]> I don't have any new on that unfortunately, that is something that is still being worked on with slow progress.
16:31:15 <jock> are going to be established, work is stopped for some reason, they are not worth it... ?
16:31:15 <IgorPec> ideas are generally acceptable, we have prepared material
16:31:32 <jock> ok thanks
16:31:45 <IgorPec> we are so overloade with this management work
16:31:59 <rpardini> (I missed the Amlogic topic so sneaking this in here) I've heard troubles with the BananaPi M5 (sic? the one in the last give away), does anyone know anything? I don't have it to test
16:32:03 <IgorPec> even two people were on this full time for 6 months
16:32:37 <IgorPec> too many issues to resolve, idea is developed to some degree, but executing it require again resources
16:32:54 <Heisath> Gotta go now, sorry. Thanks and I will read the log if anything happened
16:33:02 <rpardini> :salute:
16:33:07 <jock> bye, thanks!
16:33:09 <IgorPec> yes, thank you Heisath for help
16:33:12 <Werner> Bye
16:33:21 <IgorPec> thank you everyone for joining1!
16:33:52 <Werner> #endmeeting