#armbian: Armbian Release planning 23.05

Meeting started by Werner at 14:57:22 UTC (full logs).

Meeting summary

  1. check-in (Werner, 14:57:27)
  2. late topics (Werner, 15:04:37)
  3. FYI (Werner, 15:06:36)
  4. board maintainers (Werner, 15:07:49)
    1. ACTION: what to move down to unsupported, what to keep (IgorPec, 15:08:37)

  5. board maintainers - Allwinner (Werner, 15:09:18)
    1. schwar3kat via email "orangepi-r1, orangepi-r1plus-lts, orangepizeroplus All stable images were good when I last tested." (IgorPec, 15:09:27)
    2. ACTION: fix opizero2 (IgorPec, 15:12:09)
    3. AGREED: stop bumping armhf kernels further than 6.1.y (Werner, 15:16:49)
    4. IDEA: Stop calling any and all vendor kernel "current" - case in point: odroidxu4. (rpardini, 15:20:18)
    5. IDEA: Rename "legacy" kernels which are actually "vendor" kernels to BRANCH=vendor (case in point rk3588-legacy) (rpardini, 15:20:20)
    6. IDEA: changing terminology of “Maintained Hardware” vs “Unmaintained (CSC/EOL/TVB) / Other” into “Armbian maintained” vs “Community maintained” or similar. (IgorPec, 15:20:40)

  6. board maintainers - amlogic (Werner, 15:25:36)
    1. possible another legacy kernel to support VIM4 (IgorPec, 15:29:14)
    2. IDEA: split meson64 into gx, g12, and s4 families (tonymac32, 15:32:15)

  7. board maintainers - Marvell (Werner, 15:36:45)
    1. ACTION: froze mvebu 32 bit (IgorPec, 15:45:50)
    2. ACTION: froze mvebu 32 bit (IgorPec, 15:45:59)

  8. board maintainers - Rockchip (Werner, 15:46:09)
    1. IDEA: send rpardini some armhf boards (rpardini, 15:50:47)
    2. ACTION: rockchip needs further patch cleaning (IgorPec, 15:57:05)
    3. ACTION: TRS-80 adjusts setup instructions for pbp on download page (Werner, 15:59:31)
    4. IDEA: lets have instructions for board on a Markdown heredoc _inside the board file_ (rpardini, 15:59:34)
    5. wet wish to sort out 3399 legacy and bump it to 5.10.y (IgorPec, 16:06:39)

  9. board maintainers - others (Werner, 16:07:06)
    1. ACTION: change branch when upgrade mechnism works (IgorPec, 16:11:19)
    2. riscv sparks little interest. leave as is (IgorPec, 16:15:46)
    3. ACTION: also rpi kernel naming adjustement proposed (IgorPec, 16:17:46)
    4. IDEA: overlays stored in folder and copied to kernel sources for compilation instead of patched in. (tonymac32, 16:19:59)
    5. ACTION: get some apples and oranges to Richardo (IgorPec, 16:23:04)

  10. infrastructure (Werner, 16:24:12)
    1. ACTION: switching the name of current OS repisotiry (IgorPec, 16:29:48)
    2. help in CI is most welcome (IgorPec, 16:35:19)

  11. misc (Werner, 16:37:33)


Meeting ended at 16:47:12 UTC (full logs).

Action items

  1. what to move down to unsupported, what to keep
  2. fix opizero2
  3. froze mvebu 32 bit
  4. froze mvebu 32 bit
  5. rockchip needs further patch cleaning
  6. TRS-80 adjusts setup instructions for pbp on download page
  7. change branch when upgrade mechnism works
  8. also rpi kernel naming adjustement proposed
  9. get some apples and oranges to Richardo
  10. switching the name of current OS repisotiry


Action items, by person

  1. TRS-80
    1. TRS-80 adjusts setup instructions for pbp on download page
  2. UNASSIGNED
    1. what to move down to unsupported, what to keep
    2. fix opizero2
    3. froze mvebu 32 bit
    4. froze mvebu 32 bit
    5. rockchip needs further patch cleaning
    6. change branch when upgrade mechnism works
    7. also rpi kernel naming adjustement proposed
    8. get some apples and oranges to Richardo
    9. switching the name of current OS repisotiry


People present (lines said)

  1. IgorPec (219)
  2. rpardini (120)
  3. tonymac32 (47)
  4. Werner (37)
  5. TRS-80 (31)
  6. adeepv (17)
  7. DC-IRC (14)
  8. joshaspinall (9)
  9. ArmbianHelper (4)
  10. brentr (4)


Generated by MeetBot 0.1.4.