15:01:39 <Werner> #startmeeting Kereru release planning
15:01:39 <ArmbianHelper> Meeting started Sat Feb 10 15:01:39 2024 UTC.  The chair is Werner. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:39 <ArmbianHelper> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:47 <Werner> #topic checkin
15:02:22 <Werner> Alright folks, here we go again. Say hello if your brain is currently focused to this channel :)
15:03:05 <jock> hello :)
15:03:13 <IgorPec> hey
15:04:00 <Werner> Common agenda: https://docs.armbian.com/Process_Release-Model/#agenda
15:05:08 <IgorPec> i have three things to put on agenda: check critical problems before starting RC builds, find out which boards to retire and general FYI (have prepared few items)
15:06:14 <Werner> That's be late topics so yeah
15:06:19 <Werner> --testen ob das ding noch funktioniert
15:06:20 <ArmbianHelper> test whether the thing still works [de~>en]
15:07:18 <Werner> Alright, translator if necessary is available. Wanna tell us something but prefer your native language? Put -- at the very beginning of your message. It will be translated from whatever you feed in to English.
15:07:24 <IgorPec> lets wait awhile if more peole show up
15:09:15 <jock> last time I checked, only me and you Igor where in the rsvp list
15:09:48 <IgorPec> adeepv is there
15:11:04 <DC-IRC> [Discord] <Werner> @adeepv  ping
15:11:28 <IgorPec> ok
15:11:37 <DC-IRC> [OFTC] <Werner> --brückentest
15:11:39 <IgorPec> notified ... so we can started
15:11:51 <Werner> Bummer. Anyway, lets move on
15:11:57 <Werner> #topic development Allwinner
15:12:19 <DC-IRC> [Discord] <adeepv> pong)
15:12:49 <IgorPec> for allwinner we only have H618
15:12:54 <IgorPec> that is new
15:13:35 <IgorPec> and here i don't know much what is the progress, officially no board on the list, Bananapi zero is coming, but not within this release
15:13:48 <IgorPec> others I am not aware if there is any critical problem
15:13:59 <IgorPec> perhaps werner you know any ?
15:14:45 <Werner> Nothing that critical that I kept it in mind
15:15:00 <IgorPec> ok. what about retiring / advancing to supported in this segment?
15:15:46 <IgorPec> i would say to drop forums from boards that are operational, supported, but with little to no activitiy
15:16:24 <Werner> Needs to be checked. I guess there are a few that could be dropped
15:16:50 <IgorPec> like duo and prime. Also I discussed with SwartzCat to drop Orangepi R1 (H3) from supported list. Also more or less no changes
15:16:57 <Werner> #action Check forums of standard support boards with little to no activity to consider moving to csc
15:18:00 <IgorPec> this means we only Have: Bananapi Zero, Opi Zero and Zero2 in the forums at the end, IMO
15:18:00 <Werner> I could test against H3 and H6 but I think you have those in auto tests anyways?
15:18:11 <IgorPec> yes, this is in autotests
15:18:17 <Werner> Alright
15:18:33 <IgorPec> the aim here is to reduce this board count
15:19:01 <IgorPec> regarding Allwinner, this is more or less it
15:19:25 <Werner> #topic development Amlogic
15:19:45 <IgorPec> here i count on adeepv to share some info
15:20:01 <DC-IRC> [Discord] <adeepv> At the moment, I only need the PR https://armbian.atlassian.net/browse/AR-2033, everything else is fine with us.
15:20:02 <DC-IRC> [Discord] <adeepv> There are questions regarding the build system: in the standard 5.15 kernel from Ubuntu Jammy, there are issues with loop devices.
15:20:39 <IgorPec> this PR was merged few moments ago
15:20:47 <DC-IRC> [Discord] <adeepv> Lately, I've been busy with other projects, so I got a bit distracted)
15:20:47 <IgorPec> 1h ago, sorry
15:21:06 <IgorPec> ok. for loop devices - is this happening on WSL?
15:21:10 <IgorPec> this is known
15:21:32 <DC-IRC> [Discord] <adeepv> lxc vm build with jammy
15:21:43 <DC-IRC> [Discord] <adeepv> like https://github.com/jethome-iot/armbian-os/actions/runs/7853082770/job/21432909112#step:8:1106
15:22:16 <Werner> Maybe a dumb question but lxc container or actual real vm?
15:22:36 <DC-IRC> [Discord] <adeepv> sorry, migrated to incus from lxc.
15:22:52 <DC-IRC> [Discord] <adeepv> real vm. containers too bad with loop 🙂
15:23:29 <IgorPec> ok, i don't know. better to open a ticket at build framework with some logs, so we have something to start with.
15:25:00 <IgorPec> if there is no other amlogic specifc ... i won't drag KVIM1S and VIM4 ... those are on legacy kernels, also progressing  ...
15:25:05 <IgorPec> we can move on
15:25:09 <adeepv> it's strange that it only started showing up in the last week. so I haven't had a chance to react yet.
15:25:25 <adeepv> I have no other questions.
15:25:37 <IgorPec> ok
15:26:06 <Werner> #topic development Marvell
15:26:49 <IgorPec> here we can add for the record that Helios4 will be back
15:27:18 <IgorPec> as Heisath desided to keep maintaining it as he don't have time for new toy, while keeping this up is not big trouble for him
15:27:27 <Werner> #info Helios4 will be back
15:28:02 <IgorPec> that is probably all what is here
15:28:48 <Werner> #topic development Rockchip
15:28:55 <Werner> Probably the biggest thing these days
15:29:09 <IgorPec> yes, now perhaps Jock_ first
15:29:14 <jock_> thanks
15:29:39 <jock_> well 32 bits and 64 bits should be ok right now. 32 bits had that horrible issue about stats
15:30:01 <jock_> and 64 bits have had the kernel config mess
15:30:26 <jock_> but everything should be ok for all of them right now.
15:30:53 <IgorPec> we merged everything that is relevant, right?
15:31:05 <jock_> yes
15:31:32 <IgorPec> good.
15:31:33 <jock_> so I think I can wait the RC images for all the relevant boards I maintain, but we should be in good shape there too
15:32:03 <IgorPec> ok, are you good with boards you maintain. You want to change anything here?
15:32:19 <IgorPec> you have 4LTS, right?
15:33:19 <jock_> yes, I don't want to change anything
15:33:24 <IgorPec> ok
15:33:45 <jock_> I'm keeping them up to date, so it is totally ok
15:33:58 <jock_> also rk3288 tinkerboard
15:34:24 <IgorPec> aha, that's still alive and kicking
15:34:34 <jock_> indeed ;)
15:34:39 <IgorPec> is this https://forum.armbian.com/topic/16517-rk3288rk3328-legacy-multimedia-framework/
15:34:46 <IgorPec> still needed to be pinned?
15:35:07 <IgorPec> mainline vpu is now in place, right?
15:35:10 <Werner> Upstream support for Buster will end on June
15:35:13 <Werner> *in
15:35:44 <IgorPec> buster ah, no i mean, we have legacy kernel there
15:36:06 <jock_> yes everything for multimedia is pretty ok in mainline
15:36:33 <IgorPec> this seems pretty old stuff from JMCC. I wonder if I just unpin that topic as it seems outdated
15:36:45 <jock_> rk3399 and rk3328 also have h.265 patches, so multimedia framework is really legacy nowadays
15:37:28 <IgorPec> great. what about other boards? PinebookPRO, Rockpro64 (mine doesn't boot), Rockpi 4
15:38:05 <IgorPec> We have nobody doing anything there, complicated to support due to so many different revisions
15:38:47 <jock_> no news from them sorry, I have a Rockpi-E (rk3328, CSC) which is also working pretty fine except for the rtl88x1 wifi
15:38:52 <Werner> Then support must be dropped
15:39:16 <jock_> which I'm trying to let it work with rtw88, but with no real success yet
15:39:27 <IgorPec> yeah, i would also say to drop rockpi4, rockpiE kind of works
15:40:02 <IgorPec> also rockpi-s is well maintained by Roman, but there is also a problem of many revisions and not all owrks
15:40:06 <jock_> yes, rockpi-e could be promoted to supported, I usually use it to test changes on rk3328
15:40:20 <Werner> #action drop rockpi4
15:40:48 <Werner> #action promote rockpi-e (jock)
15:40:53 <IgorPec> move back rockpi-s but dunno if its worth having forums for both?
15:41:22 <IgorPec> this is another change i want to emphasises. we have some boards which are supported, but there are no users
15:42:04 <IgorPec> also from adeepv ... do we need forum in standard support section?
15:43:12 <adeepv> In the long term, yes, we plan to start worldwide sales by the end of the year.
15:44:02 <IgorPec> we could say to enable it when posts starts?
15:44:28 <IgorPec> in general, not just in this case. as it looks strange having a dedicated forum for one or two topics
15:45:15 <IgorPec> ok, lets move this up at the end, otherwise ... #rockchip
15:45:21 <IgorPec> 3588
15:45:22 <adeepv> ok. at this moment, there is no need
15:45:51 <IgorPec> 3588 Bananapi M7 is coming in
15:46:30 <IgorPec> Nanopi R6S is also not very active, one user made mosst of the posts
15:46:30 <Werner> In terms of known issues: legacy rk3588 kernel has the loadavg >=1 issue on opi5+
15:46:49 <IgorPec> is there a fix yet?
15:47:08 <IgorPec> i assume all boards have this problem?
15:47:20 <Werner> Interestingly not. Opi5 is fine
15:47:37 <Werner> No known fix I am aware of. Joshua is aware but won't take action
15:47:54 <Werner> Waste of time dealing with already dead code :)
15:48:25 <IgorPec> yes, indeed
15:48:49 <Werner> Also mainline does good progress
15:49:03 <IgorPec> yes, but that is also not really production quality
15:49:15 <Werner> Not yet, indeed
15:50:33 <IgorPec> do we have a ticket for this problem? Perhaps this is the only action here. Also I would propose to drop R6S to CSC. Its the same sh* as others and we don't plan any additional involvement
15:50:50 <IgorPec> and R1LTS too
15:51:08 <Werner> No, I don't think there is a ticket for that
15:51:48 <IgorPec> Regarding Rock 5 is similar problem as Rock 4. Not sure what to do here
15:52:24 <Werner> If there is nobody that deals with it the best is drop to csc
15:52:35 <IgorPec> ok, then lets do that
15:52:41 <Werner> #action drop rock5 to csc
15:52:49 <Werner> what about r6c? its similar to r6s?
15:53:04 <IgorPec> yes, they are the same, just a bit different configuration
15:53:09 <Werner> #action drop r6s/r6c to csc
15:54:42 <IgorPec> rock 3? anyone faimiliar how we are here?
15:55:13 <jock_> nope
15:55:35 <Werner> nope
15:55:42 <IgorPec> i am just seeing there is no much activity, so lets CSC it
15:56:00 <Werner> #action move rock3 to csc
15:56:41 <IgorPec> there is some new board from Roman at PR, but this is already out of the scope of this meeting, too new
15:56:50 <IgorPec> any other rockchip related?
15:57:00 <jock_> yes
15:57:09 <totally_not_2o> hello
15:57:20 <jock_> About the rockchip patch archives cleanup...
15:57:26 <IgorPec> aha, shoot
15:57:53 <jock_> I would open a merge request with the removal of rockpi-s family, which contains only things for the rockpi S
15:58:20 <jock_> and those are only for legacy kernel
15:58:52 <jock_> so Roman is chief there, but I would open a MR with a cleanup proposal
15:59:26 <IgorPec> oh, yeah, let Roman decide but I think he is not interersted in legacy anymore
15:59:36 <jock_> I don't know the status on mainline, but my understanding is that they work fine right now and keeping a legacy/vendor kernel for that still alive is useless
15:59:57 <jock_> *work fine in mainline
15:59:59 <IgorPec> yep, that is my understanding too
16:00:29 <IgorPec> just not all revisions are supported, but this is not possible to cover just like that
16:01:01 <jock_> perfect, just a question: do I open the MR before or after the release?
16:01:02 <IgorPec> #action remove rockpi-s legacy stuff
16:01:17 <IgorPec> leave it for next, as its not relevant to release
16:01:30 <jock_> agree
16:01:57 <jock_> I think it is done for me
16:02:02 <IgorPec> k
16:02:12 <Werner> Alright, let's move on
16:02:18 <Werner> #topic development other SoCs/families
16:02:49 <IgorPec> other - odroidxu4 - it seems hardkernel has some issues
16:03:27 <IgorPec> do we retire this board too? Problem is that 6.1.y is buggy
16:03:48 <IgorPec> vs. 5.4.y
16:03:59 <IgorPec> and both are some hybrid kernels, not mainline
16:04:45 <IgorPec> we have leave as is
16:05:22 <IgorPec> Raspberry Pi 4 and 5 seems ok
16:05:44 <IgorPec> TI AM64B is maintained by vendor, have no info, probably ok
16:05:54 <IgorPec> also here we have empty forum
16:06:19 <Werner> So no issues :)
16:06:31 <IgorPec> x86 is also fine, i would propose to enable Qemu x86 / arm64
16:06:49 <Werner> #idea  i would propose to enable Qemu x86 / arm64
16:07:00 <IgorPec> also if we look here https://www.armbian.com/download/?device_support=Staging
16:07:23 <IgorPec> we have Lenovo X13S that is used by few people and it seems alright
16:07:48 <IgorPec> Jetson Nano was fixed by someone not long time ago, but don't know how is with care taking?
16:08:09 <IgorPec> Mekotronics, Mixtile, ... all those are going to CSC
16:08:43 <IgorPec> Xiaomi PAD is maintained by Amazinfate, promoted to supported?
16:08:51 <IgorPec> Radxa E25 -> csc
16:09:01 <Werner> You can use #action too ;)
16:09:13 <IgorPec> now I am done ;)
16:09:18 <jock_> @Igor do armbian has a mechanism to send back, from time to time, a packet from installed systems to identify the installation age and board?
16:10:05 <IgorPec> no
16:10:15 <Werner> There are no metrics, only armbianmonitor -u which must be issued by the user
16:10:28 <adeepv> jock_ any internet query to servers not issued by user - bad idea
16:11:10 <jock_> indeed is a bad idea if not issued by user, but in fact it would be an opt-in survey
16:11:24 <IgorPec> we would need to develop that
16:11:59 <IgorPec> action: x13s, xiaomi to supported
16:12:10 <Werner> Kind of something like popularity-contest?
16:12:15 <IgorPec> action: meko, mixtile, jetson nano, e25 to csc
16:12:50 <jock_> many do that, if it is opt-in and it is done in good faith I see no harm and could help define which boards are still used around and needs to be kept supported
16:12:51 <Werner> You have to use the # before action, otherwise it is not recognized :)
16:13:10 <IgorPec> # action: x13s, xiaomi to supported
16:13:15 <IgorPec> # action: meko, mixtile, jetson nano, e25 to csc
16:13:23 <adeepv> space :)
16:13:30 <IgorPec> #action meko, mixtile, jetson nano, e25 to csc
16:13:38 <IgorPec> #action: x13s, xiaomi to supported
16:13:50 * IgorPec gives up if this doesn't work ;)
16:14:16 <IgorPec> ok, anything else here? moving on*
16:14:59 <Werner> #topic build system
16:15:26 <IgorPec> build system wise .. we have this nasty problm https://github.com/armbian/build/issues/6264
16:16:19 <IgorPec> this is relevant to release and what adeepv mention before regarding loop devices, which is probably host kernel problems
16:16:58 <IgorPec> #action we have to workaround systemd changes before release.
16:18:32 <IgorPec> ok
16:18:49 <Werner> That's so far for the framework?
16:19:00 <IgorPec> yeah, the rest seems fine as images are generating
16:19:06 <Werner> #topic infrastructure
16:19:10 <IgorPec> there are ofc other problems, burt nothing critical IMO
16:19:14 <IgorPec> except mentioned
16:19:38 <IgorPec> #info JSON powered download pages adds options for complex images mixing (stable, community, nightly, applications) and for images where we have boot loaders separate from image and where image is in different format (qcow2)
16:20:22 <IgorPec> this was completed this week, so now all images shows up correctly, redirector was also reworked and is up and running
16:20:37 <IgorPec> #info - documentation is getting JSON database as a center of development (WIP)
16:20:38 <adeepv> ru <-> ua mirrors?
16:21:00 <IgorPec> #action ru/ua mirrors needs to be addressed
16:21:15 <adeepv> The problem is still relevant. We need to at least prioritize mirrors within the country
16:21:15 <IgorPec> no, this was not implmented yet AFAIK
16:21:22 <IgorPec> yes, this is the idea
16:21:42 <IgorPec> but its up to Cats. We had enough of troubles with JSON switching
16:22:27 <IgorPec> this problem remains
16:22:32 <adeepv> At the moment the question is whether we will do our own fork or continue with you.
16:23:46 <IgorPec> you mean to have own repository?
16:23:53 <adeepv> The problem is that there is 90% no internet connectivity between the countries for various reasons on both sides.
16:24:26 <IgorPec> i am aware of the problem
16:24:48 <DC-IRC> [Discord] <sunmaster> How do I fsck root/boot-drive?
16:24:57 <IgorPec> but i don't know how far is cats with implementing solution
16:25:31 <adeepv> jethome own repositories is already up and running. but our users
16:25:43 <adeepv> but our users have been having a lot of trouble with updates lately (even if you don't take ideological issues into context)
16:25:58 <adeepv> it's just that the package updates aren't going through
16:26:50 <IgorPec> there are other possible workarounds that can be executed
16:26:56 <Werner> Maybe remove both ru and ua mirrors from rotation until this is fully addressed?
16:27:30 <IgorPec> live patch that would set mirror related to COUNTRY settings
16:27:42 <IgorPec> that is also an option
16:28:13 <IgorPec> just pick one and we will do it
16:30:10 <IgorPec> #action temporally disable UA and Russia apt mirrors
16:30:35 <Werner> I'd say we skip the agenda directly to misc since we overshot time once again :)
16:30:59 <Werner> #topic misc
16:31:06 <IgorPec> yes, lets close it ... i am disabling mirrors as we speak @adeepv
16:31:19 <Werner> IgorPec: you mentioned a few open topics at the beginning of this you wanna cover?
16:31:45 <IgorPec> yes, more just infos
16:31:51 <Werner> shoot
16:31:58 <IgorPec> #info few days ago one german company contacted me for platinum support on their Rockchip HW. They forgot to name the SoC
16:32:14 <Werner> oO
16:32:25 <IgorPec> #info new boards with platinum support: Bpi M7, perhaps Zero
16:32:34 <IgorPec> #info - documentation is getting JSON database as a center of development (WIP)
16:32:45 <IgorPec> #info - Swartkat is also moving to new board, undetermined atm. I have asked him to help Terrain kicking armbian-config for now
16:33:12 <IgorPec> so this is more or less all from my side.
16:34:08 <Werner> So its time to check if it crashes or does the job
16:34:14 <IgorPec> yeah!
16:34:16 <Werner> #endmeeting