#armbian: Kereru release planning

Meeting started by Werner at 15:01:39 UTC (full logs).

Meeting summary

  1. checkin (Werner, 15:01:47)
  2. development Allwinner (Werner, 15:11:57)
    1. ACTION: Check forums of standard support boards with little to no activity to consider moving to csc (Werner, 15:16:57)

  3. development Amlogic (Werner, 15:19:25)
  4. development Marvell (Werner, 15:26:06)
    1. Helios4 will be back (Werner, 15:27:27)

  5. development Rockchip (Werner, 15:28:48)
    1. ACTION: drop rockpi4 (Werner, 15:40:20)
    2. ACTION: promote rockpi-e (jock) (Werner, 15:40:48)
    3. ACTION: drop rock5 to csc (Werner, 15:52:41)
    4. ACTION: drop r6s/r6c to csc (Werner, 15:53:09)
    5. ACTION: move rock3 to csc (Werner, 15:56:00)
    6. ACTION: remove rockpi-s legacy stuff (IgorPec, 16:01:02)

  6. development other SoCs/families (Werner, 16:02:18)
    1. IDEA: i would propose to enable Qemu x86 / arm64 (Werner, 16:06:49)
    2. ACTION: meko, mixtile, jetson nano, e25 to csc (IgorPec, 16:13:30)
    3. ACTION: : x13s, xiaomi to supported (IgorPec, 16:13:38)

  7. build system (Werner, 16:14:59)
    1. ACTION: we have to workaround systemd changes before release. (IgorPec, 16:16:58)

  8. infrastructure (Werner, 16:19:06)
    1. JSON powered download pages adds options for complex images mixing (stable, community, nightly, applications) and for images where we have boot loaders separate from image and where image is in different format (qcow2) (IgorPec, 16:19:38)
    2. - documentation is getting JSON database as a center of development (WIP) (IgorPec, 16:20:37)
    3. ACTION: ru/ua mirrors needs to be addressed (IgorPec, 16:21:00)
    4. ACTION: temporally disable UA and Russia apt mirrors (IgorPec, 16:30:10)

  9. misc (Werner, 16:30:59)
    1. few days ago one german company contacted me for platinum support on their Rockchip HW. They forgot to name the SoC (IgorPec, 16:31:58)
    2. new boards with platinum support: Bpi M7, perhaps Zero (IgorPec, 16:32:25)
    3. - documentation is getting JSON database as a center of development (WIP) (IgorPec, 16:32:34)
    4. - Swartkat is also moving to new board, undetermined atm. I have asked him to help Terrain kicking armbian-config for now (IgorPec, 16:32:45)


Meeting ended at 16:34:16 UTC (full logs).

Action items

  1. Check forums of standard support boards with little to no activity to consider moving to csc
  2. drop rockpi4
  3. promote rockpi-e (jock)
  4. drop rock5 to csc
  5. drop r6s/r6c to csc
  6. move rock3 to csc
  7. remove rockpi-s legacy stuff
  8. meko, mixtile, jetson nano, e25 to csc
  9. : x13s, xiaomi to supported
  10. we have to workaround systemd changes before release.
  11. ru/ua mirrors needs to be addressed
  12. temporally disable UA and Russia apt mirrors


Action items, by person

  1. jock
    1. promote rockpi-e (jock)
  2. UNASSIGNED
    1. Check forums of standard support boards with little to no activity to consider moving to csc
    2. drop rockpi4
    3. drop rock5 to csc
    4. drop r6s/r6c to csc
    5. move rock3 to csc
    6. remove rockpi-s legacy stuff
    7. meko, mixtile, jetson nano, e25 to csc
    8. : x13s, xiaomi to supported
    9. we have to workaround systemd changes before release.
    10. ru/ua mirrors needs to be addressed
    11. temporally disable UA and Russia apt mirrors


People present (lines said)

  1. IgorPec (132)
  2. Werner (57)
  3. jock_ (29)
  4. adeepv (13)
  5. DC-IRC (11)
  6. ArmbianHelper (3)
  7. jock (2)
  8. totally_not_2o (1)


Generated by MeetBot 0.1.4.